allow people to add files to the rootfs by putting them in $(TOPDIR)/files/
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 1 Dec 2006 14:01:31 +0000 (14:01 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 1 Dec 2006 14:01:31 +0000 (14:01 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5685 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/Makefile

index e0483deb59e7414cdff5e9e495718ac5e4187c41..34eba4e3b1e75fdded00d13766f4607ad061756f 100644 (file)
@@ -55,6 +55,9 @@ install-targets: base-files-install $(INSTALL_PACKAGES)
 install:
        rm -rf $(BUILD_DIR)/root
        $(MAKE) install-targets
+       @if [ -d $(TOPDIR)/files ]; then \
+               $(CP) $(TOPDIR)/files/. $(BUILD_DIR)/root; \
+       fi
        @( \
                cd $(BUILD_DIR)/root; \
                for script in ./etc/init.d/*; do \