[backfire] backport r22517
authoragb <agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 Dec 2010 21:41:04 +0000 (21:41 +0000)
committeragb <agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 Dec 2010 21:41:04 +0000 (21:41 +0000)
[include] support unpacking of .tar.xz archives, no prereq on xzcat for now

git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@24524 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/unpack.mk

index 2cd17817e6929d216cf31acb1c8514848eb4ecfd..01516757771a17f40692e424b14f860781676406 100644 (file)
@@ -32,7 +32,11 @@ ifeq ($(strip $(UNPACK_CMD)),)
       EXT:=$(call ext,$(PKG_SOURCE:.$(EXT)=))
       DECOMPRESS_CMD:=bzcat $(DL_DIR)/$(PKG_SOURCE) |
     endif
-    ifeq ($(filter tgz tbz tbz2,$(EXT1)),$(EXT1))
+    ifeq ($(filter xz txz,$(EXT)),$(EXT))
+      EXT:=$(call ext,$(PKG_SOURCE:.$(EXT)=))
+      DECOMPRESS_CMD:=xzcat $(DL_DIR)/$(PKG_SOURCE) |
+    endif
+    ifeq ($(filter tgz tbz tbz2 txz,$(EXT1)),$(EXT1))
       EXT:=tar
     endif
     DECOMPRESS_CMD ?= cat $(DL_DIR)/$(PKG_SOURCE) |