fix the new libpthread implementation - the function table init was broken
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 13 Jan 2009 20:44:29 +0000 (20:44 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 13 Jan 2009 20:44:29 +0000 (20:44 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14027 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/uClibc/patches/200-libpthread_fix.patch [new file with mode: 0644]
toolchain/uClibc/patches/200-libpthread_static.patch [deleted file]

diff --git a/toolchain/uClibc/patches/200-libpthread_fix.patch b/toolchain/uClibc/patches/200-libpthread_fix.patch
new file mode 100644 (file)
index 0000000..8acfa3f
--- /dev/null
@@ -0,0 +1,35 @@
+--- a/libpthread/linuxthreads/libc-cancellation.c
++++ b/libpthread/linuxthreads/libc-cancellation.c
+@@ -31,9 +31,6 @@
+ weak_extern (__pthread_do_exit)
+ # endif
+-int __libc_multiple_threads attribute_hidden __attribute__((nocommon));
+-strong_alias (__libc_multiple_threads, __librt_multiple_threads)
+-
+ /* The next two functions are similar to pthread_setcanceltype() but
+    more specialized for the use in the cancelable functions like write().
+    They do not need to check parameters etc.  */
+--- a/libpthread/linuxthreads/libc_pthread_init.c
++++ b/libpthread/linuxthreads/libc_pthread_init.c
+@@ -33,6 +33,9 @@ libc_hidden_proto(memcpy)
+ libc_hidden_proto(uselocale)
+ #endif
++int __libc_multiple_threads attribute_hidden __attribute__((nocommon));
++strong_alias (__libc_multiple_threads, __librt_multiple_threads)
++
+ int *
+ __libc_pthread_init (functions)
+      const struct pthread_functions *functions;
+--- a/libpthread/linuxthreads/Makefile.in
++++ b/libpthread/linuxthreads/Makefile.in
+@@ -77,7 +77,7 @@ libpthread-a-y  += $(libpthread_OBJ:.o=.
+ else
+ libpthread-a-y  += $(libpthread_OBJ) $(libpthread-static-y)
+ endif
+-libpthread-so-y += $(libpthread_OBJ:.o=.os)
++libpthread-so-y += $(libpthread_OBJ:.o=.oS)
+ lib-a-$(UCLIBC_HAS_THREADS) += $(top_builddir)lib/libpthread.a
+ lib-so-$(UCLIBC_HAS_THREADS) += $(top_builddir)lib/libpthread.so
diff --git a/toolchain/uClibc/patches/200-libpthread_static.patch b/toolchain/uClibc/patches/200-libpthread_static.patch
deleted file mode 100644 (file)
index 269370d..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/libpthread/linuxthreads/Makefile.in
-+++ b/libpthread/linuxthreads/Makefile.in
-@@ -65,7 +65,7 @@ CFLAGS-OMIT-libc_pthread_init.c := $(CFL
- libpthread_libc_CSRC := \
-       forward.c libc-cancellation.c libc_pthread_init.c # alloca_cutoff.c
- libpthread_libc_OBJ  := $(patsubst %.c, $(libpthread_OUT)/%.o,$(libpthread_libc_CSRC))
--libc-static-y += $(libpthread_OUT)/libc_pthread_init.o
-+libc-static-y += $(libpthread_OUT)/libc_pthread_init.o $(libpthread_OUT)/libc-cancellation.o
- libc-shared-y += $(libpthread_libc_OBJ:.o=.oS)
- libpthread-static-y += $(patsubst %,$(libpthread_OUT)/%.o,$(libpthread_static_SRC))