allow targets for override generic config (GENERIC_LINUX_CONFIG:=/dev/null) for testi...
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 16 Sep 2007 14:09:57 +0000 (14:09 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 16 Sep 2007 14:09:57 +0000 (14:09 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8796 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/target.mk

index 8f072d0cd86de99bbc6bdca509a82d7fd6329cbd..c8eb76c254c03089e59347a0aa4e7f849caecc5f 100644 (file)
@@ -87,7 +87,7 @@ include $(INCLUDE_DIR)/kernel-version.mk
 GENERIC_PLATFORM_DIR := $(TOPDIR)/target/linux/generic-$(KERNEL)
 GENERIC_PATCH_DIR := $(GENERIC_PLATFORM_DIR)/patches$(shell [ -d "$(GENERIC_PLATFORM_DIR)/patches-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )
 
-GENERIC_LINUX_CONFIG:=$(firstword $(wildcard $(GENERIC_PLATFORM_DIR)/config-$(KERNEL_PATCHVER) $(GENERIC_PLATFORM_DIR)/config-default))
+GENERIC_LINUX_CONFIG?=$(firstword $(wildcard $(GENERIC_PLATFORM_DIR)/config-$(KERNEL_PATCHVER) $(GENERIC_PLATFORM_DIR)/config-default))
 LINUX_CONFIG?=$(firstword $(wildcard $(foreach subdir,$(PLATFORM_DIR) $(PLATFORM_SUBDIR),$(subdir)/config-$(KERNEL_PATCHVER) $(subdir)/config-default)))
 LINUX_SUBCONFIG?=$(firstword $(wildcard $(PLATFORM_SUBDIR)/config-$(KERNEL_PATCHVER) $(PLATFORM_SUBDIR)/config-default))
 ifeq ($(LINUX_CONFIG),$(LINUX_SUBCONFIG))