make sure iw doesn't get compiled on older kernels
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 30 Nov 2007 11:33:31 +0000 (11:33 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 30 Nov 2007 11:33:31 +0000 (11:33 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9639 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/iw/Makefile

index 36361fb3177bdb9ed179410901a747de4e48663d..024dfde24e89f3d575b27042e68332bbbe77f366 100644 (file)
@@ -38,9 +38,11 @@ MAKE_FLAGS += \
        CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/mac80211 -I$(STAGING_DIR)/usr/include/libnl -I$(STAGING_DIR)/usr/include" \
        LDFLAGS="-L$(STAGING_DIR)/usr/lib -lnl"
 
-define Package/iw/install
+ifneq ($(CONFIG_LINUX_2_6_23),)
+  define Package/iw/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/iw $(1)/usr/sbin/
-endef
+  endef
+endif
 
 $(eval $(call BuildPackage,iw))