fix inotify detection for linux 2.4 (fixes glib2 and packages that depend on it on...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 8 Oct 2008 12:07:14 +0000 (12:07 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 8 Oct 2008 12:07:14 +0000 (12:07 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12896 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/package.mk
include/site/mipsel-linux2.4-uclibc [new file with mode: 0644]

index d67a386225eacedbe82401850f6f8266358d645a..0f3d21ee9e735feee2c664588f0e921e443b7c98 100644 (file)
@@ -31,7 +31,11 @@ include $(INCLUDE_DIR)/package-bin.mk
 include $(INCLUDE_DIR)/autotools.mk
 
 override MAKEFLAGS=
-export CONFIG_SITE:=$(INCLUDE_DIR)/site/$(patsubst %gnueabi,%,$(REAL_GNU_TARGET_NAME))
+CONFIG_SITE:=$(INCLUDE_DIR)/site/$(patsubst %gnueabi,%,$(REAL_GNU_TARGET_NAME))
+ifneq ($(CONFIG_LINUX_2_4),)
+  CONFIG_SITE:=$(subst linux-,linux2.4-,$(CONFIG_SITE))
+endif
+export CONFIG_SITE
 CUR_MAKEFILE:=$(filter-out Makefile,$(firstword $(MAKEFILE_LIST)))
 SUBMAKE:=$(NO_TRACE_MAKE) $(if $(CUR_MAKEFILE),-f $(CUR_MAKEFILE))
 
diff --git a/include/site/mipsel-linux2.4-uclibc b/include/site/mipsel-linux2.4-uclibc
new file mode 100644 (file)
index 0000000..3412411
--- /dev/null
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+. $TOPDIR/include/site/mipsel-linux
+. $TOPDIR/include/site/linux-uclibc
+ac_cv_header_sys_inotify_h=no