[backfire] backport host build hook support
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 26 Feb 2011 18:48:28 +0000 (18:48 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 26 Feb 2011 18:48:28 +0000 (18:48 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@25734 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/host-build.mk
include/package.mk
rules.mk

index 75792579eb04f8cfcff430e0b30ea7dd580da107..e02f02371e64b1b18370eac58659aefcadeba14c 100644 (file)
@@ -22,6 +22,7 @@ override MAKEFLAGS=
 
 include $(INCLUDE_DIR)/download.mk
 include $(INCLUDE_DIR)/quilt.mk
 
 include $(INCLUDE_DIR)/download.mk
 include $(INCLUDE_DIR)/quilt.mk
+include $(INCLUDE_DIR)/autotools.mk
 
 Host/Patch:=$(Host/Patch/Default)
 ifneq ($(strip $(HOST_UNPACK)),)
 
 Host/Patch:=$(Host/Patch/Default)
 ifneq ($(strip $(HOST_UNPACK)),)
@@ -121,12 +122,16 @@ ifndef DUMP
   $(HOST_STAMP_PREPARED):
        @-rm -rf $(HOST_BUILD_DIR)
        @mkdir -p $(HOST_BUILD_DIR)
   $(HOST_STAMP_PREPARED):
        @-rm -rf $(HOST_BUILD_DIR)
        @mkdir -p $(HOST_BUILD_DIR)
+       $(foreach hook,$(Hooks/HostPrepare/Pre),$(call $(hook))$(sep))
        $(call Host/Prepare)
        $(call Host/Prepare)
+       $(foreach hook,$(Hooks/HostPrepare/Post),$(call $(hook))$(sep))
        touch $$@
 
   $(call Host/Exports,$(HOST_STAMP_CONFIGURED))
   $(HOST_STAMP_CONFIGURED): $(HOST_STAMP_PREPARED)
        touch $$@
 
   $(call Host/Exports,$(HOST_STAMP_CONFIGURED))
   $(HOST_STAMP_CONFIGURED): $(HOST_STAMP_PREPARED)
+       $(foreach hook,$(Hooks/HostConfigure/Pre),$(call $(hook))$(sep))
        $(call Host/Configure)
        $(call Host/Configure)
+       $(foreach hook,$(Hooks/HostConfigure/Post),$(call $(hook))$(sep))
        touch $$@
 
   $(call Host/Exports,$(HOST_STAMP_BUILT))
        touch $$@
 
   $(call Host/Exports,$(HOST_STAMP_BUILT))
@@ -142,17 +147,23 @@ ifndef DUMP
     update: host-update
 
     $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED)
     update: host-update
 
     $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED)
+               $(foreach hook,$(Hooks/HostCompile/Pre),$(call $(hook))$(sep))
                $(call Host/Compile)
                $(call Host/Compile)
+               $(foreach hook,$(Hooks/HostCompile/Post),$(call $(hook))$(sep))
                touch $$@
 
     $(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT)
                $(call Host/Install)
                touch $$@
 
     $(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT)
                $(call Host/Install)
+               $(foreach hook,$(Hooks/HostInstall/Post),$(call $(hook))$(sep))
                mkdir -p $$(shell dirname $$@)
                touch $$@
   else
     $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED)
                mkdir -p $$(shell dirname $$@)
                touch $$@
   else
     $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED)
+               $(foreach hook,$(Hooks/HostCompile/Pre),$(call $(hook))$(sep))
                $(call Host/Compile)
                $(call Host/Compile)
+               $(foreach hook,$(Hooks/HostCompile/Post),$(call $(hook))$(sep))
                $(call Host/Install)
                $(call Host/Install)
+               $(foreach hook,$(Hooks/HostInstall/Post),$(call $(hook))$(sep))
                touch $$@
   endif
   host-prepare: $(HOST_STAMP_PREPARED)
                touch $$@
   endif
   host-prepare: $(HOST_STAMP_PREPARED)
index e13cfe678c5bd3c589d667e85fbf8b3d9cd3fe71..36a1800c2c8e8d86f5994363a54831b70279a92c 100644 (file)
@@ -70,10 +70,6 @@ define Download/default
   MD5SUM:=$(PKG_MD5SUM)
 endef
 
   MD5SUM:=$(PKG_MD5SUM)
 endef
 
-define sep
-
-endef
-
 define Build/Exports/Default
   $(1) : export ACLOCAL_INCLUDE=$$(foreach p,$$(wildcard $$(STAGING_DIR)/usr/share/aclocal $$(STAGING_DIR)/usr/share/aclocal-* $$(STAGING_DIR)/host/share/aclocal $$(STAGING_DIR)/host/share/aclocal-*),-I $$(p))
   $(1) : export STAGING_PREFIX=$$(STAGING_DIR)/usr
 define Build/Exports/Default
   $(1) : export ACLOCAL_INCLUDE=$$(foreach p,$$(wildcard $$(STAGING_DIR)/usr/share/aclocal $$(STAGING_DIR)/usr/share/aclocal-* $$(STAGING_DIR)/host/share/aclocal $$(STAGING_DIR)/host/share/aclocal-*),-I $$(p))
   $(1) : export STAGING_PREFIX=$$(STAGING_DIR)/usr
index 86c8f8cf6d7ae8d235f6ec3d949cc88059335823..1a58c6ae57b47e62132e20f55f602fcfdcb5fc4d 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -27,6 +27,10 @@ merge=$(subst $(space),,$(1))
 confvar=$(call merge,$(foreach v,$(1),$(if $($(v)),y,n)))
 strip_last=$(patsubst %.$(lastword $(subst .,$(space),$(1))),%,$(1))
 
 confvar=$(call merge,$(foreach v,$(1),$(if $($(v)),y,n)))
 strip_last=$(patsubst %.$(lastword $(subst .,$(space),$(1))),%,$(1))
 
+define sep
+
+endef
+
 _SINGLE=export MAKEFLAGS=$(space);
 CFLAGS:=
 ARCH:=$(subst i486,i386,$(subst i586,i386,$(subst i686,i386,$(call qstrip,$(CONFIG_ARCH)))))
 _SINGLE=export MAKEFLAGS=$(space);
 CFLAGS:=
 ARCH:=$(subst i486,i386,$(subst i586,i386,$(subst i686,i386,$(call qstrip,$(CONFIG_ARCH)))))