Abstracted find to $(FIND) to allow use of gfind on non-GNU systems.
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 Dec 2007 18:45:20 +0000 (18:45 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 Dec 2007 18:45:20 +0000 (18:45 +0000)
Signed-off-by: Andy Boyett <agb-openwrt@padded-cell.net>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9659 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/host.mk

index d163c997dde41b75c89e3551fd3fe83f5e566fbe..00eb1f55aafef0a1072e0dfa07b4071eaee5aa86 100644 (file)
@@ -30,6 +30,9 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
                TAR=`which gtar 2>/dev/null`; \
                [ -n "$$TAR" -a -x "$$TAR" ] || TAR=`which tar 2>/dev/null`; \
                echo "TAR:=$$TAR" >> $@; \
+               FIND=`which gfind 2>/dev/null`; \
+               [ -n "$$FIND" -a -x "$$FIND" ] || FIND=`which find 2>/dev/null`; \
+               echo "FIND:=$$FIND" >> $@; \
                echo "BASH:=$(shell which bash)" >> $@; \
                if find -L /tmp -maxdepth 0 >/dev/null 2>/dev/null; then \
                        echo 'FIND_L=find -L $$(1)' >>$@; \