[cris] fix missing ptrace.h needed to build final gcc
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 12 Jan 2009 19:03:39 +0000 (19:03 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 12 Jan 2009 19:03:39 +0000 (19:03 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13995 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/kernel-headers/Makefile

index 2274ee24479861bbddf00b3f6e695baf9ac6b095..474ff6c71b710d4b59d67f1a70134df6563fc7d9 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -106,6 +106,14 @@ define Build/Install/post/lzma
                $(TOOLCHAIN_DIR)/usr/include/asm/
 endef
 
+# XXX: the following is needed to build final gcc on cris
+define Build/Install/post/cris
+       mkdir -p $(TOOLCHAIN_DIR)/usr/include/asm/arch
+       $(CP) \
+               $(PKG_BUILD_DIR)/include/asm-cris/arch/ptrace.h \
+               $(TOOLCHAIN_DIR)/usr/include/asm/arch/
+endef
+
 define Build/Install/post/mips
        $(call Build/Install/post/lzma)
 endef