Add binutils extra configure options
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 23 Oct 2007 06:23:20 +0000 (06:23 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 23 Oct 2007 06:23:20 +0000 (06:23 +0000)
Currently, we can specify extra configure options for gcc, but not
binutils.

This change adds an EXTRA_BINUTILS_CONFIG_OPTIONS config variable,
so we can add configure options for binutils.

Signed-off-by: Jeremy Kerr <jk@ozlabs.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9407 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/binutils/Config.in
toolchain/binutils/Makefile

index ce3fa99622d138ca9fb7dc75ebc41655cc7102ba..598029f1df8574f15489ed6db92b16e2ea75f880 100644 (file)
@@ -14,6 +14,13 @@ choice
 
 endchoice
 
+config EXTRA_BINUTILS_CONFIG_OPTIONS
+       string
+       prompt "Additional binutils options" if TOOLCHAINOPTS
+       default ""
+       help
+           Any additional binutils options you may want to include....
+
 config BINUTILS_VERSION
        string
        prompt "Binutils Version" if (TOOLCHAINOPTS && NULL)
index b3a68893b5872e333b3221ea814da60f9d4137bc..2ca79d3eaf9a93054fcb650c32c50fd666977f4f 100644 (file)
@@ -33,6 +33,7 @@ define Build/Configure
                --target=$(REAL_GNU_TARGET_NAME) \
                --disable-werror \
                --disable-nls \
+               $(call qstrip,$(CONFIG_EXTRA_BINUTILS_CONFIG_OPTIONS)) \
        );
 endef