Fix the platform device registration; resync kernel config
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 12 Oct 2007 10:12:02 +0000 (10:12 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 12 Oct 2007 10:12:02 +0000 (10:12 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9266 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/au1000/config-2.6.23
target/linux/au1000/files/arch/mips/au1000/mtx-1/platform.c
target/linux/au1000/patches/002-platform_devices.patch [deleted file]
target/linux/au1000/patches/006-mtx1_system_button.patch

index bc2904553d0b7329d00176ad59f7194d6a86f3b6..a79b43b872fb2dfae19de8de625865a5577e3bc1 100644 (file)
@@ -47,7 +47,6 @@ CONFIG_DEVPORT=y
 # CONFIG_DM9000 is not set
 CONFIG_DMA_NEED_PCI_MAP_STATE=y
 CONFIG_DMA_NONCOHERENT=y
-# CONFIG_DS1682 is not set
 CONFIG_DUMMY=m
 CONFIG_ELF_CORE=y
 # CONFIG_FIXED_PHY is not set
@@ -70,7 +69,6 @@ CONFIG_I2C_ALGOPCA=m
 CONFIG_I2C_ALGOPCF=m
 CONFIG_I2C_BOARDINFO=y
 CONFIG_I2C_CHARDEV=m
-# CONFIG_I2C_TAOS_EVM is not set
 # CONFIG_IDE is not set
 CONFIG_INITRAMFS_SOURCE=""
 CONFIG_LEDS_GPIO=y
@@ -181,7 +179,6 @@ CONFIG_SCHED_NO_NO_OMIT_FRAME_POINTER=y
 CONFIG_SCSI_CONSTANTS=y
 # CONFIG_SCSI_PROC_FS is not set
 CONFIG_SCSI_WAIT_SCAN=m
-# CONFIG_SENSORS_TSL2550 is not set
 CONFIG_SERIAL_8250_AU1X00=y
 # CONFIG_SERIAL_8250_EXTENDED is not set
 CONFIG_SERIAL_8250_NR_UARTS=4
index 529595fcd443efbd6e42426df1f2ca8d3eef6cda..5c7fe535414b8aec095da1af744defefac0d03bf 100644 (file)
@@ -70,5 +70,5 @@ static int __init mtx1_register_devices(void)
        return platform_add_devices(mtx1_devs, ARRAY_SIZE(mtx1_devs));
 }
 
-arch_initcall(mtx1_register_devices);
+module_init(mtx1_register_devices);
 
diff --git a/target/linux/au1000/patches/002-platform_devices.patch b/target/linux/au1000/patches/002-platform_devices.patch
deleted file mode 100644 (file)
index 193b500..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-diff --git a/arch/mips/au1000/mtx-1/Makefile b/arch/mips/au1000/mtx-1/Makefile
-index 764bf9f..4d1b8d2 100644
---- a/arch/mips/au1000/mtx-1/Makefile
-+++ b/arch/mips/au1000/mtx-1/Makefile
-@@ -7,4 +7,4 @@
- # Makefile for 4G Systems MTX-1 board.
- #
-
--lib-y := init.o board_setup.o irqmap.o
-+lib-y := init.o board_setup.o irqmap.o platform.o
index 4364a54329b6e1f083b26873d08b944a73badb61..cc452433cf6d62d534c6c9544caea8e7087f9bda 100644 (file)
@@ -15,8 +15,8 @@ diff -urN linux-2.6.16.7/arch/mips/au1000/mtx-1/Makefile linux-2.6.16.7.new/arch
 @@ -8,3 +8,4 @@
  #
  
- lib-y := init.o board_setup.o irqmap.o platform.o
-+obj-y := mtx-1_sysbtn.o
+ lib-y := init.o board_setup.o irqmap.o
++obj-y := mtx-1_sysbtn.o platform.o
 diff -urN linux-2.6.16.7/arch/mips/au1000/mtx-1/mtx-1_sysbtn.c linux-2.6.16.7.new/arch/mips/au1000/mtx-1/mtx-1_sysbtn.c
 --- linux-2.6.16.7/arch/mips/au1000/mtx-1/mtx-1_sysbtn.c       1970-01-01 01:00:00.000000000 +0100
 +++ linux-2.6.16.7.new/arch/mips/au1000/mtx-1/mtx-1_sysbtn.c   2006-04-23 14:01:17.000000000 +0200