clean up gmp and mpfr
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 6 Apr 2009 09:56:25 +0000 (09:56 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 6 Apr 2009 09:56:25 +0000 (09:56 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15114 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/gmp/Makefile
tools/mpfr/Makefile

index 4c6fac425f93eddf7e3c338cca6a892974036772..3356ae9dd1c45bc97eff3f163394084cef0588f8 100644 (file)
@@ -15,28 +15,10 @@ PKG_MD5SUM:=
 
 include $(INCLUDE_DIR)/host-build.mk
 
 
 include $(INCLUDE_DIR)/host-build.mk
 
-define Host/Configure
-       (cd $(HOST_BUILD_DIR); \
-       ./configure \
-         --prefix=$(STAGING_DIR_HOST) \
-         --build=$(GNU_HOST_NAME) \
-         --enable-static \
-         --disable-shared \
-         --enable-cxx \
-         --enable-mpbsd \
-       );
-endef
-
-define Host/Compile
-       make -C $(HOST_BUILD_DIR) all
-endef
-
-define Host/Install
-       make -C $(HOST_BUILD_DIR) install
-endef
-
-define Host/Clean
-       rm -rf $(HOST_BUILD_DIR)
-endef
+HOST_CONFIGURE_ARGS += \
+       --enable-static \
+       --disable-shared \
+       --enable-cxx \
+       --enable-mpbsd
 
 $(eval $(call HostBuild))
 
 $(eval $(call HostBuild))
index 5abb2a2c792ea587c3624212930daf1fea731d1a..17734a246a0e3944b2f336392eee72980f187ba5 100644 (file)
@@ -15,27 +15,9 @@ PKG_MD5SUM:=527147c097874340cb9cee0579dacf3b
 
 include $(INCLUDE_DIR)/host-build.mk
 
 
 include $(INCLUDE_DIR)/host-build.mk
 
-define Host/Configure
-       (cd $(HOST_BUILD_DIR); \
-       ./configure \
-         --prefix=$(STAGING_DIR_HOST) \
-         --build=$(GNU_HOST_NAME) \
-         --enable-static \
-         --disable-shared \
-         --with-gmp=$(STAGING_DIR_HOST) \
-       );
-endef
-
-define Host/Compile
-       make -C $(HOST_BUILD_DIR) all
-endef
-
-define Host/Install
-       make -C $(HOST_BUILD_DIR) install
-endef
-
-define Host/Clean
-       rm -rf $(HOST_BUILD_DIR)
-endef
+HOST_CONFIGURE_ARGS += \
+       --enable-static \
+       --disable-shared \
+       --with-gmp=$(STAGING_DIR_HOST)
 
 $(eval $(call HostBuild))
 
 $(eval $(call HostBuild))