fix the host vs native stampfile dependencies to improve quilt support
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 22 Feb 2009 23:54:05 +0000 (23:54 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 22 Feb 2009 23:54:05 +0000 (23:54 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14629 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/package.mk

index 2b28b648b21ba2e3a33797a546f557ff621b51b3..e33814e77db5c7323b4b74df7328ec191e7df9fc 100644 (file)
@@ -69,7 +69,7 @@ define Build/DefaultTargets
   $(if $(strip $(PKG_SOURCE_URL)),$(call Download,default))
   $(call Build/Autoclean)
 
-  $(STAMP_PREPARED): $(HOST_STAMP_INSTALLED)
+  $(STAMP_PREPARED):
        @-rm -rf $(PKG_BUILD_DIR)
        @mkdir -p $(PKG_BUILD_DIR)
        $(foreach hook,$(Hooks/Prepare/Pre),$(call $(hook))$(sep))
@@ -77,7 +77,7 @@ define Build/DefaultTargets
        $(foreach hook,$(Hooks/Prepare/Post),$(call $(hook))$(sep))
        touch $$@
 
-  $(STAMP_CONFIGURED): $(STAMP_PREPARED)
+  $(STAMP_CONFIGURED): $(STAMP_PREPARED) $(HOST_STAMP_INSTALLED)
        $(foreach hook,$(Hooks/Configure/Pre),$(call $(hook))$(sep))
        $(Build/Configure)
        $(foreach hook,$(Hooks/Configure/Post),$(call $(hook))$(sep))