[package] ensure CONTROL directory is created (#5683)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 17 Aug 2009 10:14:25 +0000 (10:14 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 17 Aug 2009 10:14:25 +0000 (10:14 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17293 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel.mk
include/package-ipkg.mk

index 20377af3cf80fd2851d76a04390013db548caadd..cb62e638104efa3c46aceb797fcffca621f4a752 100644 (file)
@@ -77,6 +77,7 @@ define ModuleAutoLoad
        $(3) \
        if [ -n "$$$$$$$$modules" ]; then \
                mkdir -p $(2)/etc/modules.d; \
+               mkdir -p $(2)/CONTROL; \
                echo "#!/bin/sh" > $(2)/CONTROL/postinst; \
                echo "[ -z \"\$$$$$$$$IPKG_INSTROOT\" ] || exit 0" >> $(2)/CONTROL/postinst; \
                echo ". /etc/functions.sh" >> $(2)/CONTROL/postinst; \
index 4af052c37a007ac77db3fd0b1ae9a80147673724..72d6d596b70391f7706651053b89ce88634f6032 100644 (file)
@@ -90,6 +90,7 @@ ifeq ($(DUMP),)
 
     $$(IPKG_$(1)): $(STAGING_DIR)/etc/ipkg.conf $(STAMP_BUILT) $$(IDIR_$(1))/CONTROL/control
        $(call Package/$(1)/install,$$(IDIR_$(1)))
+       mkdir -p $$(IDIR_$(1))/CONTROL
        mkdir -p $(PACKAGE_DIR)
        -find $$(IDIR_$(1)) -name 'CVS' -o -name '.svn' -o -name '.#*' | $(XARGS) rm -rf
        $(RSTRIP) $$(IDIR_$(1))