cleanup the whole addpattern / trx nonsense
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 12 Feb 2005 06:12:34 +0000 (06:12 +0000)
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 12 Feb 2005 06:12:34 +0000 (06:12 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@243 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/openwrt/openwrt.mk
target/Config.in
target/jffs2/Config.in
target/jffs2/Makefile.in
target/jffs2/jffs2root.mk
target/squashfs/Config.in
target/squashfs/Makefile.in
target/squashfs/squashfsroot.mk

index 06d0172a447bfe4f2907416e7646103777155d5a..4945e69c629ea265fc25b6340587dfd54aad1b90 100644 (file)
@@ -99,7 +99,7 @@ openwrt-mtd: $(TARGET_DIR)/$(OPENWRT_MTD_TARGET_BINARY)
 
 # trx tool
 OPENWRT_TRX_SOURCE=package/openwrt/trx.c
-OPENWRT_TRX_TARGET=$(BUILD_DIR)/trx
+OPENWRT_TRX_TARGET=$(STAGING_DIR)/bin/trx
 
 $(OPENWRT_TRX_TARGET): 
                $(CC) -o $(OPENWRT_TRX_TARGET) $(OPENWRT_TRX_SOURCE)
@@ -108,7 +108,7 @@ openwrt-trx: $(OPENWRT_TRX_TARGET)
 
 # addpattern tool
 OPENWRT_ADDPATTERN_SOURCE=package/openwrt/addpattern.c
-OPENWRT_ADDPATTERN_TARGET=$(BUILD_DIR)/addpattern
+OPENWRT_ADDPATTERN_TARGET=$(STAGING_DIR)/bin/addpattern
 
 $(OPENWRT_ADDPATTERN_TARGET): 
                $(CC) -o $(OPENWRT_ADDPATTERN_TARGET) $(OPENWRT_ADDPATTERN_SOURCE)
index c2576fd55a0691ef64d177d74d881a5efe29c69b..791741a08f617d6655f07e1d95c08a6a1428c5f6 100644 (file)
@@ -1,9 +1,5 @@
-#
-
-menu "Target Filesystem"
-
-source "target/jffs2/Config.in"
-source "target/squashfs/Config.in"
-
-endmenu
-
+choice
+       prompt "Target Root Filesystem"
+       source "target/jffs2/Config.in"
+       source "target/squashfs/Config.in"
+endchoice
index 0d79dd1ffa7d216e5c14055ece7150725a03313b..ae14ad9da08755650cc5005ffbb79d948d8a9f5f 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_TARGET_ROOTFS_JFFS2
-       bool "jffs2 root filesystem for the target device"
+       bool "jffs2"
        default n
        help
          Build a jffs2 root filesystem
index 1da4903ee6c41114a130fb9d55b2c40c27acb48c..ab8c2a8a520109efa17c5ba2c55b9283a7e3775a 100644 (file)
@@ -1,3 +1,4 @@
 ifeq ($(strip $(BR2_TARGET_ROOTFS_JFFS2)),y)
 TARGETS+=jffs2root openwrt-image-jffs2
+ROOTFS=jffs2
 endif
index 7d30f4cc983ac495bb4c5233910d4faf870ff6ca..75f55aebb56284a3832be4509ed6a41e08185708 100644 (file)
@@ -44,16 +44,3 @@ jffs2root-clean:
 
 jffs2root-dirclean:
        rm -rf $(MTD_DIR)
-
-openwrt-linux.trx.jffs2:
-       $(BUILD_DIR)/trx -o openwrt-linux.trx.jffs2 $(LINUX_DIR)/$(LINUX_BINLOC) $(IMAGE).jffs2
-
-openwrt-gs-code.bin.jffs2: openwrt-linux.trx.jffs2
-       $(BUILD_DIR)/addpattern -2 -i  openwrt-linux.trx.jffs2 -o openwrt-gs-code.bin.jffs2 -g
-
-openwrt-g-code.bin.jffs2: openwrt-gs-code.bin.jffs2
-       sed -e "1s,^W54S,W54G," < openwrt-gs-code.bin.jffs2 > openwrt-g-code.bin.jffs2
-
-openwrt-image-jffs2:   openwrt-g-code.bin.jffs2
-
-
index a4cb4d8b6bc9422816dde1bccb0dbee4a9632980..3ef5d2223bd6ad9934117eabfde36f37266a02ba 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_TARGET_ROOTFS_SQUASHFS
-       bool "squashfs (ro) root filesystem for the target device"
+       bool "squashfs"
        default n
        help
          Build a squashfs root filesystem
index e3e10066efc5acd175aed7c6a3b9e894b05f1ee2..14b7f74db0349f50aa0833df198fc5bcbaa80f45 100644 (file)
@@ -1,3 +1,4 @@
 ifeq ($(strip $(BR2_TARGET_ROOTFS_SQUASHFS)),y)
-TARGETS+=squashfsroot openwrt-image-squashfs
+TARGETS+=squashfsroot
+ROOTFS=squashfs
 endif
index fce71643fdbed38346de47b77190f6cbb96968a7..4dd6800a0d32981c6f96c95b696eb4aa07c1f8c2 100644 (file)
@@ -47,14 +47,3 @@ squashfsroot-clean:
 
 squashfsroot-dirclean:
        rm -rf $(SQUASHFS_DIR)
-
-openwrt-linux.trx.squashfs:
-       $(BUILD_DIR)/trx -o openwrt-linux.trx.squashfs $(LINUX_DIR)/$(LINUX_BINLOC) $(IMAGE).squashfs
-
-openwrt-gs-code.bin.squashfs: openwrt-linux.trx.squashfs
-       $(BUILD_DIR)/addpattern -2 -i  openwrt-linux.trx.squashfs -o openwrt-gs-code.bin.squashfs -g
-
-openwrt-g-code.bin.squashfs: openwrt-gs-code.bin.squashfs
-       sed -e "1s,^W54S,W54G," < openwrt-gs-code.bin.squashfs > openwrt-g-code.bin.squashfs
-
-openwrt-image-squashfs:        openwrt-g-code.bin.squashfs