fix shell return status of the find symlink command
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 3 Sep 2008 13:25:26 +0000 (13:25 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 3 Sep 2008 13:25:26 +0000 (13:25 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12514 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/Makefile

index e15f061a4d35d2f8590e89b9100caf9828dceac6..ecde1191baffdede062bdd1f6658c10468681d9b 100644 (file)
@@ -38,7 +38,9 @@ $(STAGING_DIR_HOST)/bin/md5sum: $(STAGING_DIR)/.prepared
        fi
 
 $(STAGING_DIR_HOST)/bin/find: $(STAGING_DIR)/.prepared
-       [ -x "$(FIND)" -a "$(FIND)" != "$@" ] && ln -sf "$(FIND)" $@
+       if [ -x "$(FIND)" -a "$(FIND)" != "$@" ]; then \
+               ln -sf "$(FIND)" $@; \
+       fi
 
 
 $(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,find md5sum)