eliminate redundancy by creating the quilt_used stampfile in the right place
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 22 Feb 2009 17:50:31 +0000 (17:50 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 22 Feb 2009 17:50:31 +0000 (17:50 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14620 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/host-build.mk
include/package-defaults.mk
include/quilt.mk
package/libertas/Makefile
package/mac80211/Makefile

index fdba1b36cbfe44e4e52d0eb70d045bebb4329372..3f714cd6821947912627e06c8d9b06c863fa7ef4 100644 (file)
@@ -27,7 +27,6 @@ ifneq ($(strip $(HOST_UNPACK)),)
   define Host/Prepare/Default
        $(HOST_UNPACK)
        $(Host/Patch)
-       $(if $(QUILT),touch $(HOST_BUILD_DIR)/.quilt_used)
   endef
 endif
 
index e0cb6e89959700f33f05db08b9ac1d405b387244..3f3273f44d1eb4b657da2ce3fa72be3810d95654 100644 (file)
@@ -39,7 +39,6 @@ ifneq ($(strip $(PKG_UNPACK)),)
   define Build/Prepare/Default
        $(PKG_UNPACK)
        $(Build/Patch)
-       $(if $(QUILT),touch $(PKG_BUILD_DIR)/.quilt_used)
   endef
 endif
 
index 4323c77b2b4f8990d21caa4690609581dc600623..77b76a6daee91d6dec0a2ff7e67942e68514486b 100644 (file)
@@ -79,11 +79,13 @@ endif
 define Host/Patch/Default
        $(if $(QUILT),rm -rf $(HOST_BUILD_DIR)/patches; mkdir -p $(HOST_BUILD_DIR)/patches)
        $(call PatchDir,$(HOST_BUILD_DIR),$(PATCH_DIR),)
+       $(if $(QUILT),touch $(HOST_BUILD_DIR)/.quilt_used)
 endef
 
 define Build/Patch/Default
        $(if $(QUILT),rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches)
        $(call PatchDir,$(PKG_BUILD_DIR),$(PATCH_DIR),)
+       $(if $(QUILT),touch $(PKG_BUILD_DIR)/.quilt_used)
 endef
 
 kernel_files=$(foreach fdir,$(GENERIC_FILES_DIR) $(FILES_DIR),$(fdir)/.)
index 1641abeeb656e381e5c6992ed2c680c7a43ce3c0..66a90c80e957ef571a54f665d1c626ad953eca43 100644 (file)
@@ -35,7 +35,6 @@ define Build/Prepare
        mkdir -p $(PKG_BUILD_DIR)
        $(CP) ./src/* $(PKG_BUILD_DIR)/
        $(Build/Patch)
-       $(if $(QUILT),touch $(PKG_BUILD_DIR)/.quilt_used)
 endef
 
 define Build/Compile
index 5573648c5cc30f1b0e3f69e1562aa45aebc5158a..fc71e9243199459dbaedce05230b388eda3d8ce6 100644 (file)
@@ -410,7 +410,6 @@ define Build/Prepare
        mkdir -p $(PKG_BUILD_DIR)
        $(PKG_UNPACK)
        $(Build/Patch)
-       $(if $(QUILT),touch $(PKG_BUILD_DIR)/.quilt_used)
        unzip -jod $(PKG_BUILD_DIR) $(DL_DIR)/$(RT61FW)
        unzip -jod $(PKG_BUILD_DIR) $(DL_DIR)/$(RT71FW)
        -unzip -jod $(PKG_BUILD_DIR) $(DL_DIR)/$(RT2860FW)