try to clean up some kernel configs
authorthepeople <thepeople@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 2 Aug 2008 02:33:15 +0000 (02:33 +0000)
committerthepeople <thepeople@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 2 Aug 2008 02:33:15 +0000 (02:33 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12067 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/usb.mk
target/linux/at91/config-2.6.25
target/linux/au1000/config-2.6.25
target/linux/iop32x/config-default
target/linux/orion/config-default
target/linux/ps3/config-2.6.25

index b40a3db23d4c2aa109a12beab4e9f030802ab833..1ba5e370e0e2b4a40eacdc9a6e8f4b158f2e3eca 100644 (file)
@@ -579,6 +579,7 @@ define KernelPackage/usb-net-hso
   TITLE:=Kernel module for Option USB High Speed Mobile Devices
   KCONFIG:= \
        CONFIG_RFKILL \
+       CONFIG_RFKILL_INPUT
        CONFIG_USB_HSO
   FILES:= \
        $(LINUX_DIR)/net/rfkill/rfkill.$(LINUX_KMOD_SUFFIX) \
index 68faf0d962864ddf538afb44f4e3b893880b37a1..761d85c9fcd8c56673725801374f4062408ccf42 100644 (file)
@@ -126,6 +126,7 @@ CONFIG_HW_CONSOLE=y
 # CONFIG_HW_RANDOM is not set
 CONFIG_HZ=128
 # CONFIG_I2C is not set
+# CONFIG_I2C_PCA is no set
 # CONFIG_IBM_NEW_EMAC_EMAC4 is not set
 # CONFIG_IBM_NEW_EMAC_RGMII is not set
 # CONFIG_IBM_NEW_EMAC_TAH is not set
@@ -246,6 +247,8 @@ CONFIG_SLABINFO=y
 # CONFIG_SOUND is not set
 # CONFIG_SPARSEMEM_STATIC is not set
 # CONFIG_SPARSEMEM_VMEMMAP_ENABLE is not set
+# CONFIG_SPI_AT91 is not set
+# CONFIG_SPI_ATMEL is not set
 CONFIG_SPLIT_PTLOCK_CPUS=4096
 CONFIG_SSB_POSSIBLE=y
 CONFIG_SYSVIPC_SYSCTL=y
index ae36c8444d6aa00176dc29f839cd98e683df95fa..87579dfdcb2bc02f2338ceb0c9f3954dc8a62447 100644 (file)
@@ -262,6 +262,7 @@ CONFIG_TICK_ONESHOT=y
 # CONFIG_TOSHIBA_RBTX4927 is not set
 # CONFIG_TOSHIBA_RBTX4938 is not set
 CONFIG_TRAD_SIGNALS=y
+# CONFIG_USBPCWATCHDOG is not set
 # CONFIG_VGASTATE is not set
 # CONFIG_VIA_RHINE is not set
 CONFIG_VIDEO_CAPTURE_DRIVERS=y
index 58b99445a215afa72d61139f8a5a13190a140f62..120349182e9a616b70fb670fd14cc47e360f15ab 100644 (file)
@@ -41,7 +41,7 @@ CONFIG_ARCH_IOP32X=y
 CONFIG_ARM=y
 # CONFIG_ARM_THUMB is not set
 # CONFIG_ARPD is not set
-# CONFIG_ARTHUR is not set
+CONFIG_ARTHUR=n
 CONFIG_ATA=m
 # CONFIG_ATA_GENERIC is not set
 # CONFIG_ATA_PIIX is not set
@@ -90,8 +90,8 @@ CONFIG_E1000_NAPI=y
 # CONFIG_E1000E is not set
 # CONFIG_FARSYNC is not set
 CONFIG_FIRMWARE_EDID=y
-# CONFIG_FPE_FASTFPE is not set
-# CONFIG_FPE_NWFPE is not set
+CONFIG_FPE_FASTFPE=n
+CONFIG_FPE_NWFPE=n
 # CONFIG_FPE_NWFPE_XP is not set
 CONFIG_FRAME_POINTER=y
 # CONFIG_HAMRADIO is not set
index 50e94b7d1e80b0ee5018814ca16543e71df5df25..514efc592c2e4a6cd7dd547a42fa1332298b74e1 100644 (file)
@@ -199,6 +199,7 @@ CONFIG_MEDIA_TUNER_TEA5767=m
 CONFIG_MEDIA_TUNER_XC2028=m
 CONFIG_MEDIA_TUNER_XC5000=m
 # CONFIG_MINIX_FS is not set
+# CONFIG_MMC_TEST is not set
 CONFIG_MTD=y
 # CONFIG_MTD_ABSENT is not set
 # CONFIG_MTD_AFS_PARTS is not set
@@ -314,6 +315,8 @@ CONFIG_SCSI_WAIT_SCAN=m
 # CONFIG_SHMEM is not set
 CONFIG_SLABINFO=y
 # CONFIG_SMC91X is not set
+# CONFIG_SND_AW2 is not set
+# CONFIG_SOC_CAMERA is not set
 # CONFIG_SOFT_WATCHDOG is not set
 # CONFIG_SOUND is not set
 # CONFIG_SPARSEMEM_STATIC is not set
@@ -373,6 +376,8 @@ CONFIG_VIDEO_V4L1=m
 CONFIG_VIDEO_V4L2=m
 CONFIG_VIDEO_V4L2_COMMON=m
 CONFIG_VM_EVENT_COUNTERS=y
+# CONFIG_VIDEO_SAA717X is not set
+# CONFIG_USB_VIDEO_CLASS is not set
 CONFIG_WAN=y
 # CONFIG_WANXL is not set
 # CONFIG_XFS_FS is not set
index 7d24caabb98cfbf6333c31848cfeb86d4426ae04..576272477a3437cd65ee9c802554fd6961c63729 100644 (file)
@@ -171,6 +171,7 @@ CONFIG_PS3_FLASH=y
 CONFIG_PPC_CELL=y
 # CONFIG_PPC_CELL_NATIVE is not set
 # CONFIG_PPC_IBM_CELL_BLADE is not set
+# CONFIG_SND_PS3 is not set
 
 #
 # Cell Broadband Engine options