fix typo in gcc version check
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 3 Aug 2008 15:04:28 +0000 (15:04 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 3 Aug 2008 15:04:28 +0000 (15:04 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12080 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch

index 48cffffcd4ff29dd6c66696535ba0292865ee6f8..17c08cd6c56273592d62237dc1aa8627e1ea9d61 100644 (file)
@@ -7,7 +7,7 @@ Index: linux-2.6.26/arch/um/Makefile-i386
  # a lot more stack due to the lack of sharing of stacklots.  Also, gcc
  # 4.3.0 needs -funit-at-a-time for extern inline functions.
 -KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0400 ] ; then \
-+KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0430 ] ; then \
++KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0403 ] ; then \
                        echo $(call cc-option,-fno-unit-at-a-time); \
                        else echo $(call cc-option,-funit-at-a-time); fi ;)