[adm5120] lzma-loader: fix compiler warnings
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 30 Jan 2008 08:23:36 +0000 (08:23 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 30 Jan 2008 08:23:36 +0000 (08:23 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10321 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/adm5120/image/lzma-loader/src/Makefile

index aad845ae07512c281a3eb4dcb2f63ab55377e184..f23d040cdbe95f4c1a48aa69ab2fb2e817c08d36 100644 (file)
@@ -37,8 +37,8 @@ BIN_FLAGS     := -O binary -R .reginfo -R .note -R .comment -R .mdebug -S
 
 CFLAGS         = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
                  -fno-strict-aliasing -fno-common -fomit-frame-pointer -G 0 -mno-abicalls -fno-pic \
-                 -ffunction-sections -pipe -mlong-calls -fno-common \
-                 -ffreestanding \
+                 -ffunction-sections -pipe -mlong-calls -fno-common -ffreestanding \
+                 -fhonour-copts \
                  -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap
 CFLAGS         += -DLOADADDR=$(LOADADDR) -D_LZMA_PROB32