upgrade to busybox 1.4.1
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 4 Feb 2007 08:41:37 +0000 (08:41 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 4 Feb 2007 08:41:37 +0000 (08:41 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6261 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/busybox/Makefile
package/busybox/patches/100-syslogd_segfault_fix.patch [deleted file]

index c1944722e340aaee14a2e5ad3f9d00e990718ed7..530b0276706d910d3a235dcb35f063386c5ea0f3 100644 (file)
@@ -9,13 +9,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
-PKG_VERSION:=1.4.0
+PKG_VERSION:=1.4.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.busybox.net/downloads \
                http://distfiles.gentoo.org/distfiles/
-PKG_MD5SUM:=f24a3c1e08bc55ec44381d588e8bcced
+PKG_MD5SUM:=5728403bce309cdabcffa414e2e64052
 PKG_CAT:=bzcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
diff --git a/package/busybox/patches/100-syslogd_segfault_fix.patch b/package/busybox/patches/100-syslogd_segfault_fix.patch
deleted file mode 100644 (file)
index 80425e3..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- busybox-1.4.0/libbb/xreadlink.c    Fri Jan 19 22:23:06 2007
-+++ busybox-1.4.0-syslogd-n/libbb/xreadlink.c  Tue Jan 23 22:35:45 2007
-@@ -36,7 +36,7 @@
- char *xmalloc_realpath(const char *path)
- {
--#ifdef __GLIBC__
-+#if defined(__GLIBC__) && !defined(__UCLIBC__)
-       /* glibc provides a non-standard extension */
-       return realpath(path, NULL);
- #else