add feature flag for display support. will be used as dependency for x.org
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 25 Oct 2007 21:08:46 +0000 (21:08 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 25 Oct 2007 21:08:46 +0000 (21:08 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9448 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/target.mk
scripts/metadata.pl
target/Config.in

index 9156789c88df4fd95a5615914a5f426f7bafae01..757d178ab3937551244c6dd45e36b89dd8b98d3a 100644 (file)
@@ -117,6 +117,9 @@ ifeq ($(DUMP),1)
     ifneq ($(CONFIG_PCMCIA)$(CONFIG_PCCARD),)
       FEATURES += pcmcia
     endif
+    ifneq ($(CONFIG_VGA_CONSOLE)$(CONFIG_FB),)
+      FEATURES += display
+    endif
 
     # remove duplicates
     FEATURES:=$(sort $(FEATURES))
index f84bd462fa3440979bac699a3ab9b753508e7943..914b5127b4ad1dbf61d88976bd371c2e6abccc2f 100755 (executable)
@@ -151,6 +151,7 @@ sub target_config_features(@) {
 
        while ($_ = shift @_) {
                /broken/ and $ret .= "\tdepends BROKEN\n";
+               /display/ and $ret .= "\tselect DISPLAY_SUPPORT\n";
                /pci/ and $ret .= "\tselect PCI_SUPPORT\n";
                /usb/ and $ret .= "\tselect USB_SUPPORT\n";
                /pcmcia/ and $ret .= "\tselect PCMCIA_SUPPORT\n";
index 0c8864f3edbd345898b986aafce81a3523845a51..2dc5ec4245b9186ba1444acf36230dc3244c4127 100644 (file)
@@ -8,6 +8,9 @@ config LINUX_2_4
 config LINUX_2_6
        bool
 
+config DISPLAY_SUPPORT
+       bool
+
 config PCI_SUPPORT
        bool