Add wget2nand from David Goodenough, useful for RouterOS to OpenWrt migration
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 11 May 2007 22:15:06 +0000 (22:15 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 11 May 2007 22:15:06 +0000 (22:15 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7192 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/wget2nand/Makefile [new file with mode: 0644]
package/wget2nand/src/wget2nand [new file with mode: 0755]

diff --git a/package/wget2nand/Makefile b/package/wget2nand/Makefile
new file mode 100644 (file)
index 0000000..e029a50
--- /dev/null
@@ -0,0 +1,37 @@
+# 
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=wget2nand
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/wget2nand
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=RouterOS to OpenWrt install script
+  DEPENDS:=@LINUX_2_6_ADM5120
+  DESCRIPTION:=\
+       A tool to switch from RouterBoard RouterOS to OpenWrt
+  URL:=https://dev.openwrt.org/browser/trunk/package/wget2nand/src/wget2nand
+  VERSION:=1
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Package/wget2nand/install
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) ./src/$(PKG_NAME) $(1)/sbin/
+endef
+
+$(eval $(call BuildPackage,wget2nand))
diff --git a/package/wget2nand/src/wget2nand b/package/wget2nand/src/wget2nand
new file mode 100755 (executable)
index 0000000..5197dba
--- /dev/null
@@ -0,0 +1,71 @@
+#!/bin/sh
+# wget2nand
+# This script can be used to download a TGZ file from your build system which
+# contains the files to be installed on the NAND flash on your RB1xx card.
+# The one parameter is the URL of the TGZ file to be downloaded.
+# Licence GPL V2
+# Author david.goodenough@linkchoose.co.uk
+# Based on cf2nand from RB532 support
+. /etc/functions.sh
+
+[ -d /tmp/wget2nand ] && {
+       echo "/tmp/wget2nand already exists"
+       exit 1
+}
+
+# first get an address for eth0 using udhcpc
+killall udhcpc
+/sbin/udhcpc -i eth0
+
+# need to find the wget server from the command line
+url=$1
+[ -z "$url" ] && {
+       echo "No URL specified for image TGZ"
+       echo "Usage : $0 URL"
+       exit 1
+} 
+
+boot="$(find_mtd_part 'RouterBoard NAND Boot')"
+main="$(find_mtd_part 'RouterBoard NAND Main')"
+[ -z "$boot" -o -z "$main" ] && {
+       echo "Cannot find NAND Flash partitions"
+       exit 1
+}
+
+echo "Erasing filesystem."
+mtd erase Boot 2>/dev/null >/dev/null
+mtd erase Main 2>/dev/null >/dev/null
+
+echo "Mounting $main as new root and $boot as boot partition"
+
+mkdir /tmp/wget2nand/
+mkdir /tmp/wget2nand-boot
+mount -t yaffs2 "$main" /tmp/wget2nand/
+mount -t yaffs2 "$boot" /tmp/wget2nand-boot
+
+echo "Copying filesystem..."
+( wget -O - $url/openwrt-adm5120-2.6-rootfs.tgz) | ( cd /tmp/wget2nand/; tar xvz )
+wget -O /tmp/wget2nand-boot/kernel $url/openwrt-adm5120-2.6-vmlinux 
+
+# update the command line on the kernel to boot from the right place
+[ ! -e /sbin/patch-cmdline ] && {
+       echo "Cannot find patch-cmdline"
+       exit 1
+}
+
+echo "Patching the kernel command line"
+/sbin/patch-cmdline /tmp/wget2nand-boot/kernel "root=/dev/mtdblock1 rootfstype=yaffs2 init=/etc/preinit "
+chmod +x /tmp/wget2nand-boot/kernel
+
+# make sure everything is written before we unmount the partitions
+sync
+ls /tmp/wget2nand-boot/
+ls /tmp/wget2nand/
+# unmount the partitions and remove the directories into which they were mounted
+umount /tmp/wget2nand-boot
+umount /tmp/wget2nand
+rmdir /tmp/wget2nand-boot
+rmdir /tmp/wget2nand
+
+# all done
+echo "Image written, you can now reboot.  Remember to change the boot source to Boot from Nand"