I do not believe that users will cleanup kernelsource, when switching
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 23 Feb 2005 21:50:10 +0000 (21:50 +0000)
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 23 Feb 2005 21:50:10 +0000 (21:50 +0000)
rootfs. force it with scripts and Makefile changes from Felix Fietkau <nbd@vd-s.ath.cx>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@290 3c298f89-4303-0410-b956-a3cf2f4a3e73

Makefile
README
package/config/mconf.c
scripts/configtest.pl [new file with mode: 0755]
scripts/flash.sh [moved from flash.sh with 100% similarity]
target/Config.in

index 92137eac20c4e5e2b06b9440e200060e1624ff15..dfa272120bb2a02061c30ae82f7cfdd38792ada1 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -166,27 +166,48 @@ $(CONFIG)/mconf:
        fi
 
 menuconfig: $(CONFIG)/mconf
+       -touch .config
+       -cp .config .config.test
        @$(CONFIG)/mconf $(CONFIG_CONFIG_IN)
+       -./scripts/configtest.pl
 
 config: $(CONFIG)/conf
+       -touch .config
+       -cp .config .config.test
        @$(CONFIG)/conf $(CONFIG_CONFIG_IN)
+       -./scripts/configtest.pl
 
 oldconfig: $(CONFIG)/conf
+       -touch .config
+       -cp .config .config.test
        @$(CONFIG)/conf -o $(CONFIG_CONFIG_IN)
+       -./scripts/configtest.pl
 
 randconfig: $(CONFIG)/conf
+       -touch .config
+       -cp .config .config.test
        @$(CONFIG)/conf -r $(CONFIG_CONFIG_IN)
+       -./scripts/configtest.pl
 
 allyesconfig: $(CONFIG)/conf
        #@$(CONFIG)/conf -y $(CONFIG_CONFIG_IN)
        #sed -i -e "s/^CONFIG_DEBUG.*/# CONFIG_DEBUG is not set/" .config
+       -touch .config
+       -cp .config .config.test
        @$(CONFIG)/conf -o $(CONFIG_CONFIG_IN)
+       -./scripts/configtest.pl
 
 allnoconfig: $(CONFIG)/conf
+       -touch .config
+       -cp .config .config.test
        @$(CONFIG)/conf -n $(CONFIG_CONFIG_IN)
+       -./scripts/configtest.pl
 
 defconfig: $(CONFIG)/conf
+       -touch .config
+       -cp .config .config.test
        @$(CONFIG)/conf -d $(CONFIG_CONFIG_IN)
+       -./scripts/configtest.pl
 
 #############################################################
 #
diff --git a/README b/README
index c79070cfa37496f4da4842868bf01fc89ea16172..7d937e76d39d68aa238126ff9dbcaba53d03ecde 100644 (file)
--- a/README
+++ b/README
@@ -8,7 +8,7 @@ Simply running 'make' will build your firmware and a tarball
 of kernel modules. It will download all sources, build the 
 cross-compile toolchain, the kernel and all choosen applications.
 
-You can use flash.sh for remotely updating your embedded system
+You can use scripts/flash.sh for remotely updating your embedded system
 via tftp.
 
 
index 659e49cd64183ecbda497e7e546c668a233daf87..0db6f8f6c8a8d1d76e660194b0f924d1b82eeb22 100644 (file)
@@ -705,7 +705,6 @@ int main(int ac, char **av)
                conf_write(NULL);
                printf("\n\n"
                        "*** End of Buildroot configuration.\n"
-                       "*** After changing root fs, use make linux-dirclean.\n"
                        "*** Check the top-level Makefile for additional configuration options.\n\n");
        } else
                printf("\n\nYour Buildroot configuration changes were NOT saved.\n\n");
diff --git a/scripts/configtest.pl b/scripts/configtest.pl
new file mode 100755 (executable)
index 0000000..61fe8a7
--- /dev/null
@@ -0,0 +1,11 @@
+#!/usr/bin/perl
+
+my %change = (
+       'ROOTFS' => 'make linux-dirclean'
+);
+
+foreach my $change (keys %change) {
+       my $v1 = `grep '$change' .config.test`;
+       my $v2 = `grep '$change' .config`;
+       $v1 eq $v2 or system($change{$change});
+}
similarity index 100%
rename from flash.sh
rename to scripts/flash.sh
index 0fe83857c9e49d1b8cc63dbb4be23fa6817df30b..36616f07b8d61e2b0a275bc2bf218a7189819f83 100644 (file)
@@ -1,5 +1,3 @@
-comment "after changing root fs, use make linux-dirclean"
-
 choice
        prompt "Target Root Filesystem"
        source "target/jffs2/Config.in"