simplify handling of zcat - always use gzip -dc. zcat and gzcat are either broken...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 5 May 2007 10:35:12 +0000 (10:35 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 5 May 2007 10:35:12 +0000 (10:35 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7096 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/host.mk
include/unpack.mk

index 8b4ce3d24b9101ebe1ab1603da33a75decd56273..833aa83a66fb3c75204c6fe74160e4a59d3fbc15 100644 (file)
@@ -28,9 +28,6 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
                TAR=`which gtar 2>/dev/null`; \
                [ -n "$$TAR" -a -x "$$TAR" ] || TAR=`which tar 2>/dev/null`; \
                echo "TAR:=$$TAR" >> $@; \
-               ZCAT=`which gzcat 2>/dev/null`; \
-               [ -n "$$ZCAT" -a -x "$$ZCAT" ] || ZCAT=`which zcat 2>/dev/null`; \
-               echo "ZCAT:=$$ZCAT" >> $@; \
                echo "BASH:=$(shell which bash)" >> $@; \
        )
 
index b8349c9ca46d13e9f4ecf7792f97d3a0f7e4d471..500aada4620901b03dde1b09397addca3aee4b55 100644 (file)
@@ -20,7 +20,7 @@ ifeq ($(strip $(PKG_UNPACK)),)
 
     ifeq ($(filter gz tgz,$(EXT)),$(EXT))
       EXT:=$(call ext,$(PKG_SOURCE:.$(EXT)=))
-      UNPACK:=$(ZCAT) $(DL_DIR)/$(PKG_SOURCE) |
+      UNPACK:=gzip -dc $(DL_DIR)/$(PKG_SOURCE) |
     endif      
     ifeq ($(filter bzip2 bz2 bz tbz2 tbz,$(EXT)),$(EXT))
       EXT:=$(call ext,$(PKG_SOURCE:.$(EXT)=))
@@ -48,9 +48,9 @@ ifeq ($(strip $(PKG_UNPACK)),)
     ifeq ($(PKG_CAT),unzip)
       PKG_UNPACK:=$(UNZIP_CMD)
     endif
-    # replace zcat with $(ZCAT), because some system have it as gzcat
+    # replace zcat with $(ZCAT), because some system don't support it properly
     ifeq ($(PKG_CAT),zcat)
-      PKG_UNPACK:=$(ZCAT) $(DL_DIR)/$(PKG_SOURCE) | $(TAR_CMD)
+      PKG_UNPACK:=gzip -dc $(DL_DIR)/$(PKG_SOURCE) | $(TAR_CMD)
     endif
   endif
   ifneq ($(strip $(CRLF_WORKAROUND)),)