override some variables to make sure that perforce does not mess with our build process
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 7 May 2009 23:50:19 +0000 (23:50 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 7 May 2009 23:50:19 +0000 (23:50 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15705 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/toplevel.mk

index dd8fcd6f3029a183d6d18afa0f81324b21f7ec4b..2ee1518b8a8b4aff4121843aa6112c57ec5d0f9e 100644 (file)
@@ -26,6 +26,12 @@ export IS_TTY=$(shell tty -s && echo 1 || echo 0)
 export LD_LIBRARY_PATH:=$(if $(LD_LIBRARY_PATH),$(LD_LIBRARY_PATH):)$(STAGING_DIR_HOST)/lib
 export DYLD_LIBRARY_PATH:=$(if $(DYLD_LIBRARY_PATH),$(DYLD_LIBRARY_PATH):)$(STAGING_DIR_HOST)/lib
 
+# prevent perforce from messing with the patch utility
+export P4PORT=
+export P4USER=
+export P4CONFIG=
+export P4CLIENT=
+
 # make sure that a predefined CFLAGS variable does not disturb packages
 export CFLAGS=