Add the #1680 fix for GNU make versions
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 14 May 2007 17:55:00 +0000 (17:55 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 14 May 2007 17:55:00 +0000 (17:55 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7231 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/at91-2.6/image/u-boot/patches/012-make_3.81.patch [new file with mode: 0644]

diff --git a/target/linux/at91-2.6/image/u-boot/patches/012-make_3.81.patch b/target/linux/at91-2.6/image/u-boot/patches/012-make_3.81.patch
new file mode 100644 (file)
index 0000000..767493f
--- /dev/null
@@ -0,0 +1,16 @@
+diff -urN u-boot-1.1.4.orig/examples/Makefile u-boot-1.1.4/examples/Makefile
+--- u-boot-1.1.4.orig/examples/Makefile        2007-05-13 13:45:44.000000000 +0200
++++ u-boot-1.1.4/examples/Makefile     2007-05-13 13:48:43.000000000 +0200
+@@ -123,10 +123,10 @@
+       $(LD) -g $(EX_LDFLAGS) -Ttext $(LOAD_ADDR) \
+               -o $@ -e $(<:.o=) $< $(LIB) \
+               -L$(gcclibdir) -lgcc
+-%.srec:       %
++%.srec:       %.o
+       $(OBJCOPY) -O srec $< $@ 2>/dev/null
+-%.bin:        %
++%.bin:        %.o
+       $(OBJCOPY) -O binary $< $@ 2>/dev/null
+ #########################################################################