[backfire] openssl: update to v0.9.8r (CVE-2010-4180)
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 7 Dec 2011 23:07:32 +0000 (23:07 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 7 Dec 2011 23:07:32 +0000 (23:07 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@29478 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/openssl/Makefile
package/openssl/patches/110-optimize-for-size.patch
package/openssl/patches/150-no_engines.patch
package/openssl/patches/200-ocf-20100325.patch
package/openssl/patches/300-etrax_support.patch

index f9b4c0ac3eeaf7e3fc7572982af0cfaa59681000..9ca2f574db2b20fa2cc6fd65c09533c6caaaf335 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssl
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssl
-PKG_VERSION:=0.9.8p
+PKG_VERSION:=0.9.8r
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -16,7 +16,7 @@ PKG_SOURCE_URL:=http://www.openssl.org/source/ \
        ftp://ftp.funet.fi/pub/crypt/cryptography/libs/openssl/source/ \
        ftp://ftp.webmonster.de/pub/openssl/source/ \
        ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
        ftp://ftp.funet.fi/pub/crypt/cryptography/libs/openssl/source/ \
        ftp://ftp.webmonster.de/pub/openssl/source/ \
        ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
-PKG_MD5SUM:=7f24047f70364c9eabc94899e356ce39
+PKG_MD5SUM:=0352932ea863bc02b056cda7c9ac5b79
 
 PKG_BUILD_DEPENDS:=ocf-crypto-headers
 PKG_CONFIG_DEPENDS:=CONFIG_OPENSSL_ENGINE
 
 PKG_BUILD_DEPENDS:=ocf-crypto-headers
 PKG_CONFIG_DEPENDS:=CONFIG_OPENSSL_ENGINE
index ae35f50ce3f79e81cf68de7ad6e28b963831866c..9be06e6f00951028521f586370b27b8e397ef438 100644 (file)
@@ -7,5 +7,5 @@
 +# OpenWrt targets
 +"linux-openwrt","gcc:-DTERMIO \$(OPENWRT_OPTIMIZATION_FLAGS) -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC4_CHAR RC4_CHUNK DES_INT DES_UNROLL BF_PTR:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
  
 +# OpenWrt targets
 +"linux-openwrt","gcc:-DTERMIO \$(OPENWRT_OPTIMIZATION_FLAGS) -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC4_CHAR RC4_CHUNK DES_INT DES_UNROLL BF_PTR:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
  
- #### *BSD [do see comment about ${BSDthreads} above!]
- "BSD-generic32","gcc:-DTERMIOS -O3 -fomit-frame-pointer -Wall::${BSDthreads}:::BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL:${no_asm}:dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+ # Android: Linux but without -DTERMIO and pointers to headers and libs.
+ "android","gcc:-mandroid -I\$(ANDROID_DEV)/include -B\$(ANDROID_DEV)/lib -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC4_CHAR RC4_CHUNK DES_INT DES_UNROLL BF_PTR:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
index ed34698a85979c37f0325a17c6f36adf9f31ec8c..dcad330db04324e22f1c5ede896d0a7dea33deca 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Configure
 +++ b/Configure
 --- a/Configure
 +++ b/Configure
-@@ -1904,6 +1904,11 @@ EOF
+@@ -1907,6 +1907,11 @@ EOF
        close(OUT);
    }
    
        close(OUT);
    }
    
index e53c447e443baf6f2d3bb49f95ab17a721a9eace..d1dafb665d7fa8c9e572cdb399d1095a9cbe36ab 100644 (file)
@@ -9,7 +9,7 @@
  #
  # --test-sanity Make a number of sanity checks on the data in this file.
  #               This is a debugging tool for OpenSSL developers.
  #
  # --test-sanity Make a number of sanity checks on the data in this file.
  #               This is a debugging tool for OpenSSL developers.
-@@ -554,6 +556,10 @@ my %table=(
+@@ -557,6 +559,10 @@ my %table=(
  ##### Compaq Non-Stop Kernel (Tandem)
  "tandem-c89","c89:-Ww -D__TANDEM -D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED=1 -D_TANDEM_SOURCE -DB_ENDIAN::(unknown):::THIRTY_TWO_BIT:::",
  
  ##### Compaq Non-Stop Kernel (Tandem)
  "tandem-c89","c89:-Ww -D__TANDEM -D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED=1 -D_TANDEM_SOURCE -DB_ENDIAN::(unknown):::THIRTY_TWO_BIT:::",
  
@@ -20,7 +20,7 @@
  );
  
  my @MK1MF_Builds=qw(VC-WIN64I VC-WIN64A
  );
  
  my @MK1MF_Builds=qw(VC-WIN64I VC-WIN64A
-@@ -610,6 +616,8 @@ my $montasm=1;   # but "no-montasm" is d
+@@ -613,6 +619,8 @@ my $montasm=1;   # but "no-montasm" is d
  my $no_asm=0;
  my $no_dso=0;
  my $no_gmp=0;
  my $no_asm=0;
  my $no_dso=0;
  my $no_gmp=0;
@@ -29,7 +29,7 @@
  my @skip=();
  my $Makefile="Makefile";
  my $des_locl="crypto/des/des_locl.h";
  my @skip=();
  my $Makefile="Makefile";
  my $des_locl="crypto/des/des_locl.h";
-@@ -758,6 +766,14 @@ PROCESS_ARGS:
+@@ -761,6 +769,14 @@ PROCESS_ARGS:
                        {
                        exit(&test_sanity());
                        }
                        {
                        exit(&test_sanity());
                        }
@@ -44,7 +44,7 @@
                elsif (/^--strict-warnings/)
                        {
                        $strict_warnings = 1;
                elsif (/^--strict-warnings/)
                        {
                        $strict_warnings = 1;
-@@ -1055,6 +1071,7 @@ foreach (sort (keys %disabled))
+@@ -1058,6 +1074,7 @@ foreach (sort (keys %disabled))
                        print " OPENSSL_NO_$ALGO";
                
                        if (/^err$/)    { $flags .= "-DOPENSSL_NO_ERR "; }
                        print " OPENSSL_NO_$ALGO";
                
                        if (/^err$/)    { $flags .= "-DOPENSSL_NO_ERR "; }
@@ -52,7 +52,7 @@
                        elsif (/^asm$/) { $no_asm = 1; }
                        }
                else
                        elsif (/^asm$/) { $no_asm = 1; }
                        }
                else
-@@ -1184,6 +1201,16 @@ if (!$no_krb5)
+@@ -1187,6 +1204,16 @@ if (!$no_krb5)
                   $withargs{"krb5-dir"} ne "";
        }
  
                   $withargs{"krb5-dir"} ne "";
        }
  
index 74c9442d53aa6fc12bdab96e6a619cf56af9bceb..ca2a909bfb75d2ae05185f774d80fee870353e4c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Configure
 +++ b/Configure
 --- a/Configure
 +++ b/Configure
-@@ -403,6 +403,10 @@ my %table=(
+@@ -406,6 +406,10 @@ my %table=(
  "QNX6",       "gcc:-DTERMIOS::::-lsocket::${no_asm}:dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
  "QNX6-i386",  "gcc:-DL_ENDIAN -DTERMIOS -O2 -Wall::::-lsocket:${x86_gcc_des} ${x86_gcc_opts}:${x86_elf_asm}:dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
  
  "QNX6",       "gcc:-DTERMIOS::::-lsocket::${no_asm}:dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
  "QNX6-i386",  "gcc:-DL_ENDIAN -DTERMIOS -O2 -Wall::::-lsocket:${x86_gcc_des} ${x86_gcc_opts}:${x86_elf_asm}:dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",