[tools] m4 is now available, sorry for trouble
authorralph <ralph@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 22 Mar 2009 18:31:54 +0000 (18:31 +0000)
committerralph <ralph@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 22 Mar 2009 18:31:54 +0000 (18:31 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14972 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/Makefile

index 5a7e8149ea1347b4804c99472150427fec0f8c32..88755aeadd8b9e7a3be3cfffc8db5f136d35cdbc 100644 (file)
@@ -9,12 +9,14 @@
 curdir:=tools
 
 # subdirectories to descend into
-$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config autoconf automake $(if $(CONFIG_CCACHE),ccache) bison $(if $(CONFIG_powerpc),dtc) quilt $(if $(CONFIG_GCC_VERSION_4_3),gmp mpfr) yaffs2
+$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config m4 autoconf automake $(if $(CONFIG_CCACHE),ccache) bison $(if $(CONFIG_powerpc),dtc) quilt $(if $(CONFIG_GCC_VERSION_4_3),gmp mpfr) yaffs2
 
 # builddir dependencies
 $(curdir)/squashfs/compile := $(curdir)/lzma/install
 $(curdir)/quilt/compile := $(curdir)/sed/install
 $(curdir)/dtc/compile := $(curdir)/bison/install
+$(curdir)/autoconf/compile := $(curdir)/m4/install
+$(curdir)/automake/compile := $(curdir)/m4/install
 
 # preparatory work
 $(STAGING_DIR)/.prepared: $(TMP_DIR)/.build