include default package set in .target.mk
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 10 Jan 2007 16:01:07 +0000 (16:01 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 10 Jan 2007 16:01:07 +0000 (16:01 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6061 3c298f89-4303-0410-b956-a3cf2f4a3e73

scripts/gen_target_mk.pl

index 0e4d50a74cad2edc80c39e0c1657649abaf4cbd1..2492478f9b69979ecf00fde0764b46e37aea3cdd 100755 (executable)
@@ -70,7 +70,7 @@ foreach $target (@target) {
   $profiles_eval .= "
 \$(eval \$(call Profile,$conf\_$profile->{id}))"
        }
-       print <<EOF
+       print "
 ifeq (\$(CONFIG_LINUX_$conf),y)
   define Target
     KERNEL:=$target->{kernel}
@@ -78,9 +78,10 @@ ifeq (\$(CONFIG_LINUX_$conf),y)
     LINUX_VERSION:=$target->{version}
     LINUX_RELEASE:=$target->{release}
     LINUX_KARCH:=$target->{karch}
+    DEFAULT_PACKAGES:=".join(" ", @{$target->{packages}})."
   endef$profiles_def
 endif$profiles_eval
 
-EOF
+"
 }
 print "\$(eval \$(call Target))\n";