fix the path to the yealink module (#1944)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 30 Jun 2007 12:09:22 +0000 (12:09 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 30 Jun 2007 12:09:22 +0000 (12:09 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7788 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/usb.mk

index 18e711e0beae087eab31436757cd854d0d53c1ad..1add87557e8146f4ea6629544335fe1779279480 100644 (file)
@@ -21,6 +21,11 @@ ifeq ($(KERNEL_PATCHVER),2.6.21)
 endif
 USBHID_DIR?=drivers/hid/usbhid
 
+ifeq ($(KERNEL_PATCHVER),2.6.21)
+  USBINPUT_DIR:=usb/input
+endif
+USBINPUT_DIR?=input/misc
+
 define usbdep
   SUBMENU:=$(USBMENU)
   DEPENDS:=kmod-usb-core $(1)
@@ -415,7 +420,7 @@ define KernelPackage/usb-yealink
   TITLE:=USB Yealink VOIP phone
   DESCRIPTION:=Kernel support for Yealink VOIP phone
   KCONFIG:=$(CONFIG_USB_YEALINK)
-  FILES:=$(LINUX_DIR)/drivers/usb/input/yealink.ko
+  FILES:=$(LINUX_DIR)/drivers/$(USBINPUT_DIR)/yealink.ko
   AUTOLOAD:=$(call AutoLoad,70,yealink)
 endef
 $(eval $(call KernelPackage,usb-yealink))