[tools] genext2fs: update to 1.4.1
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 17 Feb 2009 03:05:10 +0000 (03:05 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 17 Feb 2009 03:05:10 +0000 (03:05 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14536 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/image.mk
tools/genext2fs/Makefile
tools/genext2fs/patches/01-remove_getline.patch [deleted file]

index 6ac177d2e4c5445d32d7f13e88787a2d625bb3c5..2b239ca3a37211c88946a17a50d2f1e45131acf7 100644 (file)
@@ -90,7 +90,7 @@ ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
   E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_FSPART)*1024)))
 
   define Image/mkfs/ext2
-               $(STAGING_DIR_HOST)/bin/genext2fs -U -b $(E2SIZE) -I $(CONFIG_TARGET_ROOTFS_MAXINODE) -d $(TARGET_DIR)/ $(KDIR)/root.ext2
+               $(STAGING_DIR_HOST)/bin/genext2fs -U -b $(E2SIZE) -N $(CONFIG_TARGET_ROOTFS_MAXINODE) -d $(TARGET_DIR)/ $(KDIR)/root.ext2
                $(call Image/Build,ext2)
   endef
 endif
index eef75ddec7c1a83d44c1307678ca75b0f88da4e6..5878b5c04340c876508eb97c2e74f813835965d8 100644 (file)
@@ -9,12 +9,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=genext2fs
-PKG_VERSION:=1.4rc1
+PKG_VERSION:=1.4.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://superb-west.dl.sourceforge.net/sourceforge/
-PKG_MD5SUM:=664431bf6737df1c265500e1f0b5d40c
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=@SF/genext2fs
+PKG_MD5SUM:=b7b6361bcce2cedff1ae437fadafe53b
 
 include $(INCLUDE_DIR)/host-build.mk
 
diff --git a/tools/genext2fs/patches/01-remove_getline.patch b/tools/genext2fs/patches/01-remove_getline.patch
deleted file mode 100644 (file)
index d09404c..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-diff -urN genext2fs-1.4rc1/genext2fs.c genext2fs-1.4rc1.new/genext2fs.c
---- genext2fs-1.4rc1/genext2fs.c       2005-05-17 18:29:10.000000000 +0200
-+++ genext2fs-1.4rc1.new/genext2fs.c   2007-01-03 15:21:16.000000000 +0100
-@@ -243,48 +243,6 @@
- }
- #endif // defined SNPRINTF_STORAGE_CLASS
--#if defined(__APPLE__) && defined(__GNUC__)
--// getline() replacement for Darwin, might work on other systems
--// written according to the getline man page included with Debian Linux
--ssize_t 
--getline(char **lineptr, size_t *n, FILE *stream)
--{
--      char *buf = *lineptr;   // could be NULL, in which case we allocate
--      size_t bufsize = *n;    // current buffer size, adjust if we (re)alloc
--      
--      char *temp = NULL;
--      size_t tempsize = 0;
--      
--      // temp is not a C string and we don't own the buffer it points into
--      // must copy into a malloced buffer and NULL terminate
--      temp = fgetln(stream, &tempsize);
--      if(!temp) return -1;
--      
--      tempsize++; // adjust for NULL terminator
--      if(buf) {
--              // check if we have to reallocate
--              if(bufsize < tempsize) {
--                      bufsize = tempsize;
--                      buf = (char*)realloc(buf, tempsize);
--                      if(!buf) return -1;
--              }
--      } else {
--              bufsize = tempsize;
--              buf = (char*)malloc(bufsize);
--              if(!buf) return -1;
--      }
--      
--      memcpy(buf, temp, tempsize-1);
--      buf[tempsize-1] = '\0';
--      
--      // give new pointer and size back, nondestructive if we didn't change anything..
--      *n = bufsize;
--      *lineptr = buf;
--      
--      return (ssize_t)(tempsize-1);   // don't include the NULL terminator, per getline man page
--}
--#endif
--
- // Convert a numerical string to a float, and multiply the result by an
- // SI-style multiplier if provided; supported multipliers are Ki, Mi, Gi, k, M
- // and G.