Added udp-broadcast-relay, corrected missing Makefile lines for tinyproxy
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 1 Feb 2006 11:57:57 +0000 (11:57 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 1 Feb 2006 11:57:57 +0000 (11:57 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3108 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/Config.in
package/Makefile
package/udp-broadcast-relay/Config.in [new file with mode: 0644]
package/udp-broadcast-relay/Makefile [new file with mode: 0644]
package/udp-broadcast-relay/ipkg/udp-broadcast-relay.control [new file with mode: 0644]

index 1210bec9e048076787ed227f53f006acf7399d7f..6f1c5fe300f0ed5bc0418d5f863408b0b3169446 100644 (file)
@@ -136,8 +136,10 @@ source "package/srelay/Config.in"
 source "package/tmsnc/Config.in"
 source "package/tcpdump/Config.in"
 source "package/tinc/Config.in"
+source "package/tinyproxy/Config.in"
 source "package/tor/Config.in"
 source "package/ttcp/Config.in"
+source "package/udp-broadcast-relay/Config.in"
 source "package/ulogd/Config.in"
 source "package/updatedd/Config.in"
 source "package/vgp/Config.in"
index 18888b72c94e23dce7d1355178196a6ce690d960..5e29f88073906cd4aeec2f613a21903c77fc5f36 100644 (file)
@@ -215,9 +215,11 @@ package-$(BR2_PACKAGE_SRELAY) += srelay
 package-$(BR2_PACKAGE_STRACE) += strace
 package-$(BR2_PACKAGE_TCPDUMP) += tcpdump
 package-$(BR2_PACKAGE_TINC) += tinc
+package-$(BR2_PACKAGE_TINYPROXY) += tinyproxy
 package-$(BR2_PACKAGE_TOR) += tor
 package-$(BR2_PACKAGE_TTCP) += ttcp
 package-$(BR2_PACKAGE_UCLIBCXX) += uclibc++
+package-$(BR2_PACKAGE_UDP_BROADCAST_RELAY) += udp-broadcast-relay
 package-$(BR2_PACKAGE_ULOGD) += ulogd
 package-$(BR2_PACKAGE_UPDATEDD) += updatedd
 package-$(BR2_COMPILE_USBUTILS) += usbutils
@@ -266,6 +268,7 @@ $(INSTALL_PACKAGES): base-files-install
 amwall-compile: libamsel-compile
 arpd-compile: libpcap-compile libdnet-compile libevent-compile
 arpwatch-compile: libpcap-compile
+atftp-compile: readline-compile
 avahi-compile: libdaemon-compile expat-compile libgdbm-compile
 bind-compile: openssl-compile
 clinkc-compile: expat-compile
diff --git a/package/udp-broadcast-relay/Config.in b/package/udp-broadcast-relay/Config.in
new file mode 100644 (file)
index 0000000..da3c224
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_UDP_BROADCAST_RELAY
+       prompt "udp-broadcast-relay............... listens for packets on a specified UDP broadcast port."
+       tristate
+       default m if CONFIG_DEVEL
+       help
+               This program listens for packets on a specified UDP broadcast port. When a packet is received, it sends that packet to all specified interfaces but the one it came from as though it originated from the original sender.
+
+               The primary purpose of this is to allow games on machines on separated local networks (Ethernet, WLAN) that use udp broadcasts to find each other to do so.
+
+               It also works on ppp links, so you can log in from windows boxes (e.g. using pptp) and play LAN-based games together. Currently, you have to care about upcoming or downgoing interfaces yourself.
+         
+               http://www.joachim-breitner.de/udp-broadcast-relay/
diff --git a/package/udp-broadcast-relay/Makefile b/package/udp-broadcast-relay/Makefile
new file mode 100644 (file)
index 0000000..99033e2
--- /dev/null
@@ -0,0 +1,35 @@
+# $Id: Makefile 1146 2005-06-05 13:32:28Z nbd $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=udp-broadcast-relay
+PKG_VERSION:=0.3
+PKG_RELEASE:=1
+PKG_MD5SUM:=a32f983b7063d6ac670e6b22be9b9d24
+
+PKG_SOURCE_URL:=http://www.joachim-breitner.de/udp-broadcast-relay/files/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,UDP_BROADCAST_RELAY,udp-broadcast-relay,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(TARGET_CC) $(PKG_BUILD_DIR)/main.c -o $(PKG_BUILD_DIR)/$(PKG_NAME)
+       touch $@
+
+$(IPKG_UDP_BROADCAST_RELAY): 
+       mkdir -p $(IDIR_UDP_BROADCAST_RELAY)/usr/sbin
+       cp $(PKG_BUILD_DIR)/$(PKG_NAME) $(IDIR_UDP_BROADCAST_RELAY)/usr/sbin/
+       $(STRIP) $(IDIR_UDP_BROADCAST_RELAY)/usr/sbin/*
+       $(IPKG_BUILD) $(IDIR_UDP_BROADCAST_RELAY) $(PACKAGE_DIR)
+
+mostlyclean:
+       $(MAKE) -C $(PKG_BUILD_DIR) clean
+       rm -f $(PKG_BUILD_DIR)/.built
diff --git a/package/udp-broadcast-relay/ipkg/udp-broadcast-relay.control b/package/udp-broadcast-relay/ipkg/udp-broadcast-relay.control
new file mode 100644 (file)
index 0000000..f83247a
--- /dev/null
@@ -0,0 +1,4 @@
+Package: udp-broadcast-relay
+Priority: optional
+Section: net
+Description: This program listens for packets on a specified UDP broadcast port. When a packet is received, it sends that packet to all specified interfaces but the one it came from as though it originated from the original sender.