add iw utility (untested)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 30 Nov 2007 11:30:37 +0000 (11:30 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 30 Nov 2007 11:30:37 +0000 (11:30 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9637 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/iw/Makefile [new file with mode: 0644]

diff --git a/package/iw/Makefile b/package/iw/Makefile
new file mode 100644 (file)
index 0000000..36361fb
--- /dev/null
@@ -0,0 +1,46 @@
+# 
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=iw
+PKG_REV:=11b24c28b802bae2abda8f46d457df60fa602594
+PKG_VERSION:=20071130_$(PKG_REV)
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://git.sipsolutions.net/iw.git
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_BUILD_DEPENDS:=mac80211 libnl
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/iw
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=cfg80211 interface configuration utility
+  URL:=http://git.sipsolutions.net/?p=iw.git
+  DEPENDS:=@!TARGET_avr32 @!TARGET_etrax +libnl
+endef
+
+define Build/Configure
+       $(CP) $(PKG_BUILD_DIR)/defconfig $(PKG_BUILD_DIR)/.config
+endef
+
+MAKE_FLAGS += \
+       CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/mac80211 -I$(STAGING_DIR)/usr/include/libnl -I$(STAGING_DIR)/usr/include" \
+       LDFLAGS="-L$(STAGING_DIR)/usr/lib -lnl"
+
+define Package/iw/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/iw $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,iw))