when regenerating an ipkg package, make sure the entire ipkg build dir is cleaned...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 19 Aug 2009 15:12:54 +0000 (15:12 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 19 Aug 2009 15:12:54 +0000 (15:12 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17313 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/package-ipkg.mk

index 72d6d596b70391f7706651053b89ce88634f6032..5d5c826842b33c721c2d33691fbe63ac25b84759 100644 (file)
@@ -57,8 +57,9 @@ ifeq ($(DUMP),)
     $(eval $(call BuildIPKGVariable,$(1),postinst))
     $(eval $(call BuildIPKGVariable,$(1),prerm))
     $(eval $(call BuildIPKGVariable,$(1),postrm))
-    $$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH)
+    $$(IDIR_$(1))/CONTROL/control: $(STAMP_BUILT)
        @rm -f $(PACKAGE_DIR)/$(1)_*
+       rm -rf $$(IDIR_$(1))
        mkdir -p $$(IDIR_$(1))/CONTROL
        echo "Package: $(1)" > $$(IDIR_$(1))/CONTROL/control
        echo "Version: $(VERSION)" >> $$(IDIR_$(1))/CONTROL/control
@@ -107,9 +108,6 @@ ifeq ($(DUMP),)
 
     clean: $(1)-clean
 
-    $(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH): $(STAMP_PREPARED)
-       -@rm -f $(PKG_BUILD_DIR)/.version-$(1)_* 2>/dev/null
-       @touch $$@
   endef
 
   $(STAGING_DIR)/etc/ipkg.conf: