[backfire] merge r26230
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 18 Mar 2011 18:28:36 +0000 (18:28 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 18 Mar 2011 18:28:36 +0000 (18:28 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@26231 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
package/base-files/files/etc/hotplug.d/net/10-net

index d58e17df62ebcecb963d4188168d6075ac7006ce..af14cb44bb1287f4672508626dd77a9c90c30f64 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2010 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 # Copyright (C) 2010 Vertical Communications
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=43.14
+PKG_RELEASE:=43.15
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index 0886c74c59661d7670c509cc7e4662666b2ae9d0..c006b9c255ff6793205f0800f5edddc31e73e2d1 100644 (file)
@@ -12,20 +12,23 @@ addif() {
        # PPP devices are configured by pppd, no need to run setup_interface here
        case "$INTERFACE" in
                ppp*|3g-*) return 0;;
-               ath*) return 0;;
-               wlan*) return 0;;
        esac
 
        scan_interfaces
        local cfg="$(find_config "$INTERFACE")"
 
-       # check the autoload setting
-       config_get auto "$cfg" auto
-       case "$auto" in
-               1|on|enabled) setup_interface "$INTERFACE";;
+       case "$INTERFACE" in
+               # Skip wireless parent interfaces
+               ath[0-9]|wlan[0-9]) ;;
+               *)
+                       # check the autoload setting
+                       config_get auto "$cfg" auto
+                       case "$auto" in
+                               1|on|enabled) setup_interface "$INTERFACE";;
+                       esac
+               ;;
        esac
 
-
        # find all vlan configurations for this interface and set them up as well
        for ifc in $interfaces; do
                config_get iftype "$ifc" type