[backfire] merge r28160
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 4 Sep 2011 10:22:25 +0000 (10:22 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 4 Sep 2011 10:22:25 +0000 (10:22 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@28161 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/uhttpd/Makefile
package/uhttpd/src/uhttpd-file.c

index 7276b2019001ea269d4b02fc2fd9fb31e00a5b8b..ca537a4c1ca05b3eade343c85c37f6eaca3607a0 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
-PKG_RELEASE:=23.1
+PKG_RELEASE:=23.2
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 PKG_BUILD_DEPENDS := libcyassl liblua
index fda86d72631031c7f1884e58590a99a0df3c0c63..816a69124ed47d1e214152aedfff5ac05a777fb5 100644 (file)
@@ -1,7 +1,7 @@
 /*
  * uhttpd - Tiny single-threaded httpd - Static file handler
  *
- *   Copyright (C) 2010 Jo-Philipp Wich <xm@subsignal.org>
+ *   Copyright (C) 2010-2011 Jo-Philipp Wich <xm@subsignal.org>
  *
  *  Licensed under the Apache License, Version 2.0 (the "License");
  *  you may not use this file except in compliance with the License.
@@ -37,7 +37,7 @@ static const char * uh_file_mime_lookup(const char *path)
 
                while( e >= path )
                {
-                       if( (*e == '.') && !strcasecmp(&e[1], m->extn) )
+                       if( (*e == '.' || *e == '/') && !strcasecmp(&e[1], m->extn) )
                                return m->mime;
 
                        e--;