[package] base-files: clear ip addresses on interfaces that are about to be added...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 16 Sep 2009 14:21:19 +0000 (14:21 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 16 Sep 2009 14:21:19 +0000 (14:21 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17596 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
package/base-files/files/lib/network/config.sh

index d87253b4dda5c68d42669a4aeceee5dcd1622b14..6995601a28c374af0d7bf39979eb8a6abd48240a 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=30
+PKG_RELEASE:=31
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
index bfadf40c89e8577ab16f488e15c647b6c5dec926..fbbf0e119b2036d074e6da1a83ee6d8fc33d05ca 100755 (executable)
@@ -123,6 +123,7 @@ prepare_interface() {
                                                append newdevs "$dev"
                                        done
                                        uci_set_state network "$config" device "$newdevs"
+                                       $DEBUG ifconfig "$iface" 0.0.0.0
                                        $DEBUG brctl addif "br-$config" "$iface"
                                        # Bridge existed already. No further processing necesary
                                } || {
@@ -131,6 +132,7 @@ prepare_interface() {
                                        $DEBUG brctl addbr "br-$config"
                                        $DEBUG brctl setfd "br-$config" 0
                                        $DEBUG ifconfig "br-$config" up
+                                       $DEBUG ifconfig "$iface" 0.0.0.0
                                        $DEBUG brctl addif "br-$config" "$iface"
                                        $DEBUG brctl stp "br-$config" $stp
                                        # Creating the bridge here will have triggered a hotplug event, which will