[backfire] merge r23279
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 6 Oct 2010 21:22:17 +0000 (21:22 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 6 Oct 2010 21:22:17 +0000 (21:22 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@23280 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
package/base-files/files/lib/network/config.sh

index 7de4af351c5a26a3a8b708efe20f489906a4f1d5..2b986049eeb3873b0e4c399e56b5e935e425aef8 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=43.6
+PKG_RELEASE:=43.7
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index 674e7216b92bd6c7e6cf130de4d118191e61aed6..bf7d15cc977942e40e09abfe7d6be52c9583ab99 100755 (executable)
@@ -343,12 +343,13 @@ setup_interface() {
                        local pidfile="/var/run/dhcp-${iface}.pid"
                        service_kill udhcpc "$pidfile"
 
-                       local ipaddr netmask hostname proto1 clientid broadcast
+                       local ipaddr netmask hostname proto1 clientid vendorid broadcast
                        config_get ipaddr "$config" ipaddr
                        config_get netmask "$config" netmask
                        config_get hostname "$config" hostname
                        config_get proto1 "$config" proto
                        config_get clientid "$config" clientid
+                       config_get vendorid "$config" vendorid
                        config_get_bool broadcast "$config" broadcast 0
 
                        [ -z "$ipaddr" ] || \
@@ -363,6 +364,7 @@ setup_interface() {
                                ${ipaddr:+-r $ipaddr} \
                                ${hostname:+-H $hostname} \
                                ${clientid:+-c $clientid} \
+                               ${vendorid:+-V $vendorid} \
                                -b -p "$pidfile" $broadcast \
                                ${dhcpopts:- -O rootpath -R &}
                ;;