add i8x0 audio driver
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 3 Dec 2007 21:21:17 +0000 (21:21 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 3 Dec 2007 21:21:17 +0000 (21:21 +0000)
Signed-off-by: Jan Willies <jan@willies.info>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9652 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/sound.mk

index 7faf387ba265fb270a9300f994038f50641b95ff..98e265fea78ca47eb7837c7f9d0b7de49a22372e 100644 (file)
@@ -69,3 +69,20 @@ endef
 
 $(eval $(call KernelPackage,sound-core))
 
+define KernelPackage/sound-i8x0
+  SUBMENU:=$(SOUND_MENU)
+  TITLE:=Intel/SiS/nVidia/AMD/ALi AC97 Controller
+  DEPENDS:=kmod-sound-core
+  KCONFIG:=CONFIG_SND_INTEL8X0
+  FILES:=$(LINUX_DIR)/sound/pci/snd-intel8x0.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,35,snd-i8x0)
+endef
+
+define KernelPackage/sound-i8x0/description
+ support for the integrated AC97 sound device on motherboards
+ with Intel/SiS/nVidia/AMD chipsets, or ALi chipsets using 
+ the M5455 Audio Controller.
+endef
+
+$(eval $(call KernelPackage,sound-i8x0))
+