don't abort if the operation is failing
authorralph <ralph@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Mar 2009 17:42:29 +0000 (17:42 +0000)
committerralph <ralph@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Mar 2009 17:42:29 +0000 (17:42 +0000)
( if the board is connected via NFS files might be created by root and can't be changed at this point of time )

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14729 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/image.mk

index 7de2d6346e7fbd078dbdf8b0dab9430b475155bd..3341f10e5095aafdd4f8615287d342410efc3270 100644 (file)
@@ -103,9 +103,9 @@ endif
 
 
 define Image/mkfs/prepare/default
-       find $(TARGET_DIR) -type f -not -perm +0100 -not -name 'ssh_host*' | $(XARGS) chmod 0644
-       find $(TARGET_DIR) -type f -perm +0100 | $(XARGS) chmod 0755
-       find $(TARGET_DIR) -type d | $(XARGS) chmod 0755
+       find $(TARGET_DIR) -type f -not -perm +0100 -not -name 'ssh_host*' | $(XARGS) chmod 0644
+       find $(TARGET_DIR) -type f -perm +0100 | $(XARGS) chmod 0755
+       find $(TARGET_DIR) -type d | $(XARGS) chmod 0755
        $(INSTALL_DIR) $(TARGET_DIR)/tmp
        chmod 0777 $(TARGET_DIR)/tmp
 endef