Add a USES_TGZ config.in variable, so that RB1xx profiles can use it
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 18 Jul 2007 14:11:44 +0000 (14:11 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 18 Jul 2007 14:11:44 +0000 (14:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8039 3c298f89-4303-0410-b956-a3cf2f4a3e73

Config.in
scripts/metadata.pl
target/Config.in
target/linux/adm5120-2.6/profiles/RB1xx.mk

index 0bced5c0214bf9a0f06c54eaefaf0711f7957b3a..705c24ad2fd74e828faacf1a4f68e03f25929696 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -36,7 +36,7 @@ menu "Target Images"
 
        config TARGET_ROOTFS_TGZ
                bool "tgz"
-               default y if !USES_SQUASHFS && !USES_JFFS2
+               default y if USES_TGZ
                depends !TARGET_ROOTFS_INITRAMFS
                help
                  Build a compressed tar archive of the the root filesystem
index 484d4205f44c04af8e5fe1218f93e01e1bdba80f..313efe75db0b5eec21cb002a6fb8cb02325a8dee 100755 (executable)
@@ -253,6 +253,7 @@ sub target_config_features(@) {
                /squashfs/ and $ret .= "\tselect USES_SQUASHFS\n";
                /jffs2/ and $ret .= "\tselect USES_JFFS2\n";
                /ext2/ and $ret .= "\tselect USES_EXT2\n";
+               /tgz/ and $ret .= "\tselect USES_TGZ\n";
        }
        return $ret;
 }
index e506512726f1fbd2cd1a312c6f05069df9db3647..627940eb2e95df0d9a91e0a60f39857689ead71c 100644 (file)
@@ -35,6 +35,9 @@ config USES_JFFS2
 config USES_EXT2
        bool
 
+config USES_TGZ
+       bool
+
 config PROFILE_KCONFIG 
        bool
 
index 9dd3de09735858fdfc322ab866a6a5d7688f8c7f..3d61cedc85bcddb8a3a5a8212d1a60449a93a726 100644 (file)
@@ -8,6 +8,7 @@
 define Profile/RouterBoard
   NAME:=RouterBoard RB1xx
   PACKAGES:=kmod-madwifi
+  FEATURES+=tgz
 endef
 
 define Profile/RouterBoard/Description