add a configuration option to enable full c99 math in libm. this is needed for funct...
authorpavlov <pavlov@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 26 Oct 2006 17:16:13 +0000 (17:16 +0000)
committerpavlov <pavlov@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 26 Oct 2006 17:16:13 +0000 (17:16 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5302 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/Config.in
toolchain/uClibc/Makefile

index 7b0a0aaeeed8f078496f283511446497804656a2..e89cdf6345b2b56d728788e92aba64ce0711c908 100644 (file)
@@ -26,7 +26,14 @@ config LARGEFILE
        depends on !cris
        default y
        help
-           Enable large file (files > 2 GB) support
+               Enable large file (files > 2 GB) support
+
+config C99_MATH
+       bool
+       prompt "Enable full C99 math support?" if TOOLCHAINOPTS
+       default n
+       help
+               Enable if you need full C99 math in libm
 
 config SOFT_FLOAT
        bool
index b640405ddc04dfcda70125033d03be4bcb9a7ada..7fdba8aded05b7644ecf50727e1fdcf7a565c3df 100644 (file)
@@ -51,6 +51,9 @@ endif
        $(SED) 's,.*UCLIBC_HAS_WCHAR.*,UCLIBC_HAS_WCHAR=y,g' $(PKG_BUILD_DIR)/.config
 ifeq ($(CONFIG_SOFT_FLOAT),y)
        $(SED) 's,.*HAS_FPU.*,HAS_FPU=n\nUCLIBC_HAS_FLOATS=y\nUCLIBC_HAS_SOFT_FLOAT=y,g' $(PKG_BUILD_DIR)/.config
+endif
+ifeq ($(CONFIG_C99_MATH),y)
+       $(SED) 's,.*DO_C99_MATH.*,DO_C99_MATH=y,g' $(PKG_BUILD_DIR)/.config
 endif
        mkdir -p $(TOOLCHAIN_BUILD_DIR)/uClibc_dev/usr/include
        mkdir -p $(TOOLCHAIN_BUILD_DIR)/uClibc_dev/usr/lib