add missing binutils patches
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 7 Mar 2005 16:50:56 +0000 (16:50 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 7 Mar 2005 16:50:56 +0000 (16:50 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@343 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/binutils/all/210-cflags.patch [new file with mode: 0644]
toolchain/binutils/all/400-mips-ELF_MAXPAGESIZE-4k.patch [new file with mode: 0644]

diff --git a/toolchain/binutils/all/210-cflags.patch b/toolchain/binutils/all/210-cflags.patch
new file mode 100644 (file)
index 0000000..dc67d3c
--- /dev/null
@@ -0,0 +1,32 @@
+diff -urN binutils-2.14.90.0.6/bfd/doc/Makefile.am binutils-2.14.90.0.6.new/bfd/doc/Makefile.am
+--- binutils-2.14.90.0.6/bfd/doc/Makefile.am   2003-07-23 10:08:09.000000000 -0500
++++ binutils-2.14.90.0.6.new/bfd/doc/Makefile.am       2004-03-01 16:05:16.000000000 -0600
+@@ -55,10 +55,10 @@
+ MKDOC = chew$(EXEEXT_FOR_BUILD)
+ $(MKDOC): chew.o
+-      $(CC_FOR_BUILD) -o $(MKDOC) chew.o $(CFLAGS) $(LOADLIBES) $(LDFLAGS)
++      $(CC_FOR_BUILD) -o $(MKDOC) chew.o $(CFLAGS_FOR_BUILD) $(LOADLIBES) $(LDFLAGS)
+ chew.o: chew.c
+-      $(CC_FOR_BUILD) -c -I.. -I$(srcdir)/.. -I$(srcdir)/../../include -I$(srcdir)/../../intl -I../../intl $(H_CFLAGS) $(CFLAGS) $(srcdir)/chew.c
++      $(CC_FOR_BUILD) -c -I.. -I$(srcdir)/.. -I$(srcdir)/../../include -I$(srcdir)/../../intl -I../../intl $(H_CFLAGS) $(CFLAGS_FOR_BUILD) $(srcdir)/chew.c
+ protos: libbfd.h libcoff.h bfd.h
+diff -urN binutils-2.14.90.0.6/bfd/doc/Makefile.in binutils-2.14.90.0.6.new/bfd/doc/Makefile.in
+--- binutils-2.14.90.0.6/bfd/doc/Makefile.in   2003-07-23 10:08:09.000000000 -0500
++++ binutils-2.14.90.0.6.new/bfd/doc/Makefile.in       2004-03-01 16:05:03.000000000 -0600
+@@ -469,10 +469,10 @@
+ $(MKDOC): chew.o
+-      $(CC_FOR_BUILD) -o $(MKDOC) chew.o $(CFLAGS) $(LOADLIBES) $(LDFLAGS)
++      $(CC_FOR_BUILD) -o $(MKDOC) chew.o $(CFLAGS_FOR_BUILD) $(LOADLIBES) $(LDFLAGS)
+ chew.o: chew.c
+-      $(CC_FOR_BUILD) -c -I.. -I$(srcdir)/.. -I$(srcdir)/../../include -I$(srcdir)/../../intl -I../../intl $(H_CFLAGS) $(CFLAGS) $(srcdir)/chew.c
++      $(CC_FOR_BUILD) -c -I.. -I$(srcdir)/.. -I$(srcdir)/../../include -I$(srcdir)/../../intl -I../../intl $(H_CFLAGS) $(CFLAGS_FOR_BUILD) $(srcdir)/chew.c
+ protos: libbfd.h libcoff.h bfd.h
diff --git a/toolchain/binutils/all/400-mips-ELF_MAXPAGESIZE-4k.patch b/toolchain/binutils/all/400-mips-ELF_MAXPAGESIZE-4k.patch
new file mode 100644 (file)
index 0000000..a8ae110
--- /dev/null
@@ -0,0 +1,12 @@
+diff -urN binutils-2.14.90.0.8.test/bfd/elf32-mips.c binutils-2.14.90.0.8/bfd/elf32-mips.c
+--- binutils-2.14.90.0.8.test/bfd/elf32-mips.c 2004-01-14 22:07:43.000000000 +0100
++++ binutils-2.14.90.0.8/bfd/elf32-mips.c      2005-03-03 23:44:00.000000000 +0100
+@@ -1611,7 +1611,7 @@
+ /* The SVR4 MIPS ABI says that this should be 0x10000, and Linux uses
+    page sizes of up to that limit, so we need to respect it.  */
+-#define ELF_MAXPAGESIZE                       0x10000
++#define ELF_MAXPAGESIZE                       0x1000
+ #define elf32_bed                     elf32_tradbed
+ /* Include the target file again for this target.  */