Make sure we will build USB hid support
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 3 Apr 2008 13:51:14 +0000 (13:51 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 3 Apr 2008 13:51:14 +0000 (13:51 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10719 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/usb.mk

index f3035f47274e5621a402c0d3115e38178902ff23..bfe14f642dd810b8e5f81d0a121ac0e5eb8b7ec4 100644 (file)
@@ -563,7 +563,7 @@ $(eval $(call KernelPackage,usb-net-cdc-ether))
 define KernelPackage/usb-hid
   $(call usbdep,@LINUX_2_6 +kmod-input-core +kmod-input-evdev)
   TITLE:=Support for USB Human Input Devices
-  KCONFIG:=CONFIG_USB_HID
+  KCONFIG:=CONFIG_HID_SUPPORT=y CONFIG_USB_HID
   FILES:=$(LINUX_DIR)/drivers/$(USBHID_DIR)/usbhid.ko
   AUTOLOAD:=$(call AutoLoad,70,usbhid)
 endef