Enable management frame protection in hostapd, and make it configurable
authorthepeople <thepeople@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 24 Mar 2010 00:22:19 +0000 (00:22 +0000)
committerthepeople <thepeople@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 24 Mar 2010 00:22:19 +0000 (00:22 +0000)
in /etc/config/wireless. Since ath9k is currently the only driver that
supports MFP, it will only be enabled when ath9k is enabled.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20396 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/hostapd/Makefile
package/hostapd/files/hostapd.sh

index 002cd5328b319ce766cea16e982c8087230b9382..4c261f3cae3b4a611802a39de3ad5eaab9db205e 100644 (file)
@@ -54,7 +54,8 @@ DRIVER_MAKEOPTS= \
        CONFIG_DRIVER_NL80211=$(CONFIG_PACKAGE_kmod-mac80211) \
        CONFIG_DRIVER_MADWIFI=$(CONFIG_PACKAGE_kmod-madwifi) \
        CONFIG_DRIVER_HOSTAP=$(CONFIG_PACKAGE_kmod-hostap) \
-       CONFIG_IEEE80211N=$(CONFIG_PACKAGE_kmod-ath9k)
+       CONFIG_IEEE80211N=$(CONFIG_PACKAGE_kmod-ath9k) \
+       CONFIG_IEEE80211W=$(CONFIG_PACKAGE_kmod-ath9k)
 
 ifeq ($(LOCAL_TYPE),supplicant)
   ifeq ($(LOCAL_VARIANT),full)
index c83c06df8654da399b2a117f4946ff38c337e7dd..78dcf82f0ba6616dbdc5be47018e557e6cfefe90 100644 (file)
@@ -106,6 +106,13 @@ hostapd_set_bss_options() {
        append "$var" "ssid=$ssid" "$N"
        [ -n "$bridge" ] && append "$var" "bridge=$bridge" "$N"
        [ -n "$ieee80211d" ] && append "$var" "ieee80211d=$ieee80211d" "$N"
+
+       [ "$wpa" -ge "2" ] && config_get ieee80211w "$vif" ieee80211w
+       case "$ieee80211w" in
+               [012])
+                       append "$var" "ieee80211w=$ieee80211w" "$N"
+               ;;
+       esac
 }
 
 hostapd_setup_vif() {