compress the kernel that resides on the nand memory
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 20 Jul 2007 14:33:15 +0000 (14:33 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 20 Jul 2007 14:33:15 +0000 (14:33 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8073 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/rb532-2.6/image/Makefile

index 6e2319c5fb148f2e8f364e5c9ac834f3bc35030e..3cdba39432dcbc5dc0389a476d3c85cc5cb6bc59 100644 (file)
@@ -49,8 +49,7 @@ define Image/cmdline/squashfs
 block2mtd.block2mtd=/dev/cfa2,65536 root=/dev/mtdblock0 rootfstype=squashfs init=/etc/preinit
 endef
 
-# TGZ images should be used with a yaffs2 rootfs
-define Image/cmdline/tgz
+define Image/cmdline/yaffs2
 root=/dev/mtdblock1 rootfstype=yaffs2 init=/etc/preinit
 endef
 
@@ -59,4 +58,15 @@ define Image/Build
        ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin 4 $(KDIR)/vmlinux.elf $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
 endef
 
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
+  define Image/Prepare
+       $(STAGING_DIR)/bin/patch-cmdline $(KDIR)/vmlinux '$(strip $(call Image/cmdline/yaffs2)) '
+       cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
+       $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean compile   
+  endef
+  define Image/BuildKernel
+       $(CP) $(KDIR)/loader.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux
+  endef
+endif
+
 $(eval $(call BuildImage))