add cloog and ppl to the tools build for the graphite framework in gcc 4.4
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Nov 2009 00:47:21 +0000 (00:47 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Nov 2009 00:47:21 +0000 (00:47 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18264 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/Makefile
tools/cloog/Makefile [new file with mode: 0644]
tools/ppl/Makefile [new file with mode: 0644]

index 0d91b1f95627f5791d50be151867699eda008335..8a5f36c2846d6eef92e4c87226fab793f500da62 100644 (file)
@@ -19,6 +19,11 @@ tools-$(CONFIG_CCACHE) += ccache
 tools-$(CONFIG_powerpc) += dtc
 tools-dep += lzma
 
+ifdef CONFIG_GCC_VERSION_4_4
+  tools-y += ppl cloog
+  $(curdir)/cloog/compile := $(curdir)/ppl/install
+endif
+
 # builddir dependencies
 $(curdir)/pkg-config/compile := $(curdir)/sed/install
 $(curdir)/squashfs/compile := $(curdir)/lzma-old/install
diff --git a/tools/cloog/Makefile b/tools/cloog/Makefile
new file mode 100644 (file)
index 0000000..e2043b1
--- /dev/null
@@ -0,0 +1,42 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=cloog-ppl
+PKG_VERSION:=0.15.7
+
+PKG_SOURCE_URL:=ftp://gcc.gnu.org/pub/gcc/infrastructure
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=6455e7875daac5bd885545c71c3f2001
+
+include $(INCLUDE_DIR)/host-build.mk
+
+unexport CFLAGS
+
+ifeq ($(HOST_OS),Darwin)
+  GNU_HOST_NAME:=
+  HOST_CONFIGURE_ARGS:=$(filter-out --target= --build= --host=,$(HOST_CONFIGURE_ARGS))
+endif
+
+HOST_CONFIGURE_VARS += \
+       LIBS=-lstdc++
+
+HOST_CONFIGURE_ARGS += \
+       --enable-static \
+       --disable-shared \
+       --with-ppl=$(BUILD_DIR_HOST)
+
+define Host/Configure
+       (cd $(HOST_BUILD_DIR)/$(3); \
+               $(HOST_CONFIGURE_CMD) \
+               $(HOST_CONFIGURE_VARS) \
+               $(HOST_CONFIGURE_ARGS); \
+       )
+endef
+
+
+$(eval $(call HostBuild))
diff --git a/tools/ppl/Makefile b/tools/ppl/Makefile
new file mode 100644 (file)
index 0000000..c9c09c5
--- /dev/null
@@ -0,0 +1,38 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ppl
+PKG_VERSION:=0.10.2
+
+PKG_SOURCE_URL:=ftp://gcc.gnu.org/pub/gcc/infrastructure
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=e7dd265afdeaea81f7e87a72b182d875
+
+include $(INCLUDE_DIR)/host-build.mk
+
+unexport CFLAGS
+
+ifeq ($(HOST_OS),Darwin)
+  GNU_HOST_NAME:=
+  HOST_CONFIGURE_ARGS:=$(filter-out --target= --build= --host=,$(HOST_CONFIGURE_ARGS))
+endif
+
+HOST_CONFIGURE_ARGS += \
+       --enable-static \
+       --disable-shared
+
+define Host/Configure
+       (cd $(HOST_BUILD_DIR)/$(3); \
+               $(HOST_CONFIGURE_CMD) \
+               $(HOST_CONFIGURE_VARS) \
+               $(HOST_CONFIGURE_ARGS); \
+       )
+endef
+
+
+$(eval $(call HostBuild))