add genext2fs to build ext2 filesystem images
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 22 Jul 2006 16:33:33 +0000 (16:33 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 22 Jul 2006 16:33:33 +0000 (16:33 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4213 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/image.mk
toolchain/Makefile
toolchain/ext2fs/Makefile [new file with mode: 0644]

index 87d6815ee834cc42c8b33f07612b57f8bd10977f..ba3cfb8afa9968232416d83f0430d521d33d9273 100644 (file)
@@ -47,7 +47,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
   
   ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
     define Image/mkfs/ext2
-               genext2fs -q -b 4096 -I 1500 -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
+               $(STAGING_DIR)/bin/genext2fs -q -b 4096 -I 1500 -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
                $(call Image/Build,ext2)
     endef
   endif
index 4ffc46fb3462089e81cf9ae26e6c761d43398a28..92069acb9850c954169f27c0c559b89c5b8ce02a 100644 (file)
@@ -7,7 +7,7 @@
 # Main makefile for the toolchain
 #
 include $(TOPDIR)/rules.mk
-TARGETS-y:=sed kernel-headers sstrip binutils gcc uClibc ipkg-utils libnotimpl squashfs jffs2 lzma
+TARGETS-y:=sed kernel-headers sstrip binutils gcc uClibc ipkg-utils libnotimpl ext2fs squashfs jffs2 lzma
 TARGETS-$(CONFIG_GDB) += gdb
 
 TARGETS_DOWNLOAD:=$(patsubst %,%-download,$(TARGETS-y))
diff --git a/toolchain/ext2fs/Makefile b/toolchain/ext2fs/Makefile
new file mode 100644 (file)
index 0000000..0bd24f8
--- /dev/null
@@ -0,0 +1,30 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=genext2fs
+PKG_VERSION:=1.4rc1
+
+PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=664431bf6737df1c265500e1f0b5d40c
+PKG_CAT:=zcat
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) all
+endef
+
+define Build/Install
+       install -m0755 $(PKG_BUILD_DIR)/genext2fs $(STAGING_DIR)/bin/
+endef
+
+$(eval $(call HostBuild))