ar71xx: fix WNDR3700 firmware images
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 19 Dec 2009 18:10:41 +0000 (18:10 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 19 Dec 2009 18:10:41 +0000 (18:10 +0000)
WNDR3700's U-Boot loads the kernel from a squashfs image, and it does
not support squashfs 4.0.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18851 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/image/Makefile

index 92f698a35c9224ef08f7b284a9cee55ab384f7c6..b6012b21b8b647a19d49b83269c4f5fcd9301c18 100644 (file)
@@ -241,9 +241,9 @@ define Image/Build/WNDR3700
        $(STAGING_DIR_HOST)/bin/wndr3700 \
                $(KDIR)/vmlinux-$(2).uImage \
                $(KDIR)/wndr3700/image/uImage
-       $(MKSQUASHFS_CMD) \
+       $(STAGING_DIR_HOST)/bin/mksquashfs-lzma \
                $(KDIR)/wndr3700 $(KDIR)/vmlinux-$(2).uImage.squashfs.tmp \
-               -nopad -noappend -root-owned $(SQUASHFS_OPTS)
+               -nopad -noappend -root-owned -be
        -rm -rf $(KDIR)/wndr3700
        mkimage -A mips -O linux -T filesystem -C none \
                -a 0xbf070000 -e 0xbf070000 \